bug mask

I tried to brute force a Domain Credentials Cache hash with the command
oclHashcat-plus64.exe -m 1100 --gpu-watchdog=100 cache.txt -a 3 ?l?l?l?l?l?l?d?d

If I use the above command, ocl doesn't find the pass, but when I try this command, it works

D:\Desktop\oclHashcat-plus-0.07>oclHashcat-plus64.exe -m 1100 --gpu-watchdog=100 cache.txt -a 3 ?lzer?l?l?d?d
oclHashcat-plus v0.07 by atom starting...

Hashes: 4
Unique salts: 4
Unique digests: 4
Bitmaps: 8 bits, 256 entries, 0x000000ff mask, 1024 bytes
GPU-Loops: 64
GPU-Accel: 40
Password lengths range: 1 - 15
Platform: AMD compatible platform found
Watchdog: Temperature limit set to 100c
Device #1: Cayman, 2048MB, 0Mhz, 24MCU
Device #2: Cayman, 2048MB, 0Mhz, 24MCU
Device #1: Allocating 144MB host-memory
Device #1: Kernel ./kernels/4098/m1100_a3.Cayman.64.kernel (222908 bytes)
Device #2: Allocating 144MB host-memory
Device #2: Kernel ./kernels/4098/m1100_a3.Cayman.64.kernel (222908 bytes)


Status.......: Exhausted
Input.Mode...: Mask (?lzer?l?l?d?d)
Hash.Type....: DCC, mscash
Time.Running.: 1 sec
Time.Left....: 0 secs
Time.Util....: 1020.6ms/0.0ms Real/CPU, 0.0% idle
Speed........:  6888.8k c/s Real,   379.0M c/s GPU
Recovered....: 1/4 Digests, 1/4 Salts
Progress.....: 7030400/7030400 (100.00%)
Rejected.....: 0/7030400 (0.00%)
HW.Monitor.#1:  0% GPU, 66c Temp
HW.Monitor.#2:  0% GPU, 66c Temp

Started: Tue Feb 07 22:02:02 2012
Stopped: Tue Feb 07 22:02:04 2012

The masks "?lzer?l?l?d?d", "?lzert?l?d?d"... are working, but not "?l?l?l?l?l?l?d?d", "a?l?l?l?l?l?d?d", "az?l?l?l?l?d?d", "aze?l?l?l?d?d"

Hash to crack:
I can duplicate the condition in 0.07, but it works correctly in 0.08-beta.

From the 0.08-beta docs/changes.txt:
type: bug
file: kernels
desc: fixed bug in NTLM and DCC brute-force AMD kernels

Good news for you is that you can use -lite-0.09 for this and it will a) work b) be faster.
Thanks. It worked with oclhashcat-lite