Can't get Radeon HD 7470 to be seen on Ubuntu - help me find replacement?
VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Caicos XT [Radeon HD 7470/8470 / R5 235/310 OEM]

I'm tired of trying to make this work since it is an old card anyway. Will I have better luck with a newer card? I need smaller form factor card to fit in my PC case.

Any recommendations for cards that will work in a smaller PC case - and will be seen by Ubuntu and Hashcat?
Hey, AMD Catalyst for Linix driver might be of help for you with this card. Although, you will need to use hascat's --force parameter and some kernels moght not works as expected.
Thanks - I've tried to install but can't get past dependency requirements laid out in this document:

I'm so close!

I ran catalyst, get the following:

Detected X Server version 'XServer _64a' is not supported. Supported versions are X.Org 6.9 or later, up to XServer 1.10 (default:v2:x86_64:lib32:XServer _64a:none:5.8.0-38-genericSmile
Installation will not proceed.
But does anyone have a recommendation for a card that will work without all these workarounds? I feel like I'm trying really hard to make a subpar card work.
I did install it on CentOS 7.9.2009 using these commands. I bet you can get some alternative for Ubuntu working similary.

curl -O \
        && yum install -y xorg-x11-server-Xorg-1.17.2-10.el7.x86_64.rpm \
        && curl -L -O --referer \
        && yum install -y fglrx64_p_i_c-15.30.1025-1.x86_64_RHEL7_64a.rpm
I decided it was above my pay grade and not worth my while to get this old computer hashing. I found a used gaming rig on eBay with a 2080 ti and I'm going to go from there.
Getting such old cards to work with hashcat is a pain, if successful at all. And then they are usually pretty slow. The 2080Ti is a good match.