Can not start broker

I installed VCL using this tutorial

When I try to start broker on the server node, I get this (including the nonprintable characters)

root@zentrale:~/vcl-1.22# /etc/init.d/vcl start
Starting VCL...
Starting broker: /sbin/broker: 1: /sbin/broker: �: not found
/sbin/broker: 1: /sbin/broker: @�: not found
/sbin/broker: 1: /sbin/broker: �: not found
/sbin/broker: 1: /sbin/broker: cannot open �: No such file
/sbin/broker: 1: /sbin/broker: ELF: not found
/sbin/broker: 3: /sbin/broker: Syntax error: word unexpected (expecting ")")

Trying to start the binary directly doesn't work either
root@zentrale:~/vcl-1.22# /sbin/broker
-bash: /sbin/broker: cannot execute binary file

root@zentrale:~/vcl-1.22# uname -a
Linux zentrale 3.2.0-4-686-pae #1 SMP Debian 3.2.54-2 i686 GNU/Linux

Starting VCL on the client nodes with X and catalyst installed works without problems...
What's wrong?
(05-21-2014, 01:36 PM)mindphuk Wrote: Linux zentrale 3.2.0-4-686-pae #1 SMP Debian 3.2.54-2 i686 GNU/Linux

^ that's what's wrong. vcl is for x86-64 only.
I tried to run it with a 64 bit kernel too and got a similar error. I now updated bash and all other packets to 64 bit and now it runs. Thanks
Next problem is, that I get

ERROR: clCreateContext() -6

Here I found, that -6 means out of memory
However my server now runs 16gb ram
root@debian-hc:~/oclHashcat-1.20# free -h
total used free shared buffers cached
Mem: 15G 108M 15G 0B 8.1M 27M
-/+ buffers/cache: 72M 15G
Swap: 4.1G 0B 4.1G

I just installed the broker node on a xen VM and gave it 15gb but it still crashes with -6
Version of hashcat that I am running is oclHashcat v1.20 stops with
Device #1: Kernel ./kernels/4098/m0000_a1.Tahiti_1445.5_1445.5 (VM).kernel (163760 bytes)
Device #1: Kernel ./kernels/4098/markov_le_v2.Tahiti_1445.5_1445.5 (VM).kernel (135872 bytes)
Device #1: Kernel ./kernels/4098/bzero.Tahiti_1445.5_1445.5 (VM).kernel (30452 bytes)

ERROR: clCreateContext() -2 stops with -6

root@debian-hc:~/oclHashcat-1.20# ./
./oclHashcat64.bin: /usr/lib/vcl/ no version information available (required by ./oclHashcat64.bin)
oclHashcat v1.20 starting...

Device #1: Tahiti, 2966MB, 1150Mhz, 32MCU
Device #2: Tahiti, 3035MB, 1150Mhz, 32MCU
Device #3: Tahiti, 2964MB, 1000Mhz, 32MCU
Device #4: Tahiti, 3034MB, 1000Mhz, 32MCU

Hashes: 1 hashes; 1 unique digests, 1 unique salts
Bitmaps: 8 bits, 256 entries, 0x000000ff mask, 1024 bytes
Rules: 1
Applicable Optimizers:
* Zero-Byte
* Single-Hash
* Single-Salt
Watchdog: Temperature abort trigger disabled
Watchdog: Temperature retain trigger disabled
Device #1: Kernel ./kernels/4098/m0400.Tahiti_1445.5_1445.5 (VM).kernel not found in cache! Building may take a while...
Device #1: Kernel ./kernels/4098/m0400.Tahiti_1445.5_1445.5 (VM).kernel (78660 bytes)
Device #1: Kernel ./kernels/4098/bzero.Tahiti_1445.5_1445.5 (VM).kernel (30452 bytes)

ERROR: clCreateContext() -6
"out of memory" means device memory, not host memory. but this is a known issue with vcl. try restarting opencld on all of the nodes, then restart the broker.
Hm, opencl error codes are "CL_OUT_OF_HOST_MEMORY if there is a failure to allocate resources required by the OpenCL implementation on the host."

I tried to stop and restart broker and client several times, but I always get -6
I also tried to un only one node and put more RAM into the client, it has 8GB now too but it still crashes with -6

PS: I also ran htop while running a oclhashcat job but I no where see exhausting of memory. The hostnode reports around additional 150MB RAM used while running oclhashcat and the client around the same.
PS2: Sometime it stops with -2 and not -6

Something totally does not work here and I fail to figure out where the problem is
Here is a pastebin of the strace output --- maybe it could help

strace -o hashcat.str -ff ./oclHashcat64.bin -t 32 -a 7 example0.hash ?a?a?a?a example.dict
ah yeah sorry, you're correct that it is out of host memory. my fault.

anyway, at this point you should probably know that we abandoned VCL quite awhile ago for pretty much these reasons.
Uh..uhm I am confused now... how can I setup an OCL cluster without VCL?
hashtopus, disthc, boinc, your own wrapper, manually with --keyspace, -s, and -l, etc.