howto use stats processor with oclHashcat+ v0.8?
I use oclHahscat+ v0.08, ATI driver 12.4, on ubuntu 11.10.

Now oclHashcat+ can generate combinations itself, is stdin still available in oclHashcat+?

The reason is I try to use stats processor to feed into oclHashcat+. But it does not work. GPU load is 0, even when I leave out the attack-mode parameter, or when I change X from 0 to 7.

standalone SP64 generates combinations fine.
standalone oclHashcat+ works fine with attack-mode 3 and a given mask.

But in the combination "SP ... | oclHahscat+ ....."
it seems that oclHashcat+ does not receive anything and system terminated by signal 13

My command is
./sp64.bin hashcat.hcstat -1 ?u ?1?1?1?1?1 --pw-min 5 --pw-max 5 | ./
oclHashcat-plus32.exe --hash-type 2500 --attack-mode X test.hccap

The other fault is related to sample file rockyou.hcstat. When I use
./sp32.bin --pw-min 5 --pw-max 5 rockyou.hcstat

it displays an error message
'rockyou.hcstat: Could not load data'

Is it a known bug in v0.08? Or something I do wrong here?
Oi... WPA/WPA2 can't have 5 long characters string as a password!!
-You don't set --attack-mode when "stdin"ing.
-You used sp64 and then sp32, which one is yours?
-You used bin and then exe, which one is yours?
-Try to arrange your parameters:
./sp64.bin --pw-min=8 hashcat.hcstat ?u?u?u?u?u?u?u?u | ./oclHashcat-plus64.bin -m2500 test.hccap

Bottom line: You are drunk as hell!
Thank for quick reply, M@lik

Sorry I was not fully there when I copy commands to this place to post.I use
and bin
sp64 feed in to pyrit works fine

When I test feed into oclHashcat+ to use against hash and against WPA , with both I have problem. Also already take out attack-mode still no succes.

Also when I press S to see status screen, GPU load goes down after few minute from 98% to 0%. Maybe these problems are related to V0.08. Are you using V0.8?
ntk, you have to give the gpus work. reading from stdin means copying each plaintext candidate to gpu as they come in which is very slow, so gpus aren't doing any work, hence the 0% load. you need to give it some rules to fully utilize your gpus, or just accept that stdin is slow.
SP64 is very quick I test it feeding into pyrit. It works fine GPU going up to 98%, and crack with high speed immediately.

I use linux, 11.10 ubuntu, 64bits, ATI driver 12.4. my oclHashcat version is V0.8

This problem happens only when feeding into oclHashcat+. And wait for 5min GPU still not up, nothing cracked, as if stdin is disable.
there is no problem. what you are describing is normal and expected. if you want gpus to work harder, add rules.
@pixoip, thank you for your advise. But could you please elaborate a little bit more for me. Take the example command line from M@LIK, I add -t 0 to have the full key space, with 'add rule' do you mean
./sp64.bin --pw-min=8 -t 0 hashcat.hcstat ?u?u?u?u?u?u?u?u | ./oclHashcat-plus64.bin -m2500 -r /rules/best64.rule test.hccap

'rockyou.hcstat: Could not load data'

My mistake I have not got the latest hashcat utils.
I download the lastest hashcat utils, generate a new rockyou.hcstat file, and the fault has gone. Thanks for help everyone.

but the feed-in still failed

I have tried

echo '12345678' | ./pyrit -r Harkonen.cap -i - attack_passthrough
-working! My system take less then 3secs to find PW-

./mp64.bin ?d?d?d?d?d?d?d?d | ./pyrit -r Harkonen.cap -i - attack_passthrough
-working! My system take less then 3secs to find PW-

./sp64.bin --pw-min=8 hashcat.hcstat -t 0 ?d?d?d?d?d?d?d?d?d?d | ./oclHashcat-plus64.bin -m2500 Harkonen.hccap

./sp64.bin --pw-min=8 hashcat.hcstat -t 0 ?d?d?d?d?d?d?d?d?d?d | ./oclHashcat-plus64.bin -m2500 -r /rules/best64.rule Harkonen.hccap

./mp64.bin ?d?d?d?d?d?d?d?d | ./oclHashcat-plus64.bin -m2500 -r /rules/best64.rule Harkonen.hccap
- GPU gone up but still no password found-

echo '12345678' | ./oclHashcat-plus64.bin -m2500 -r /rules/best64.rule Harkonen.hccap

echo '12345678' | ./oclHashcat-plus64.bin -m2500 Harkonen.hccap
have found the fault.

I have to run with sudo

./mp64 ?d?d?d?d?d?d?d?d | sudo ./oclHashcat-plus64.bin -m 2500 Harkonen.hccap -o foundharkonen.txt

please close this thread. thanks.
with sudo I manage with certain mask configuration to find password. But it is still not solve the problem of stdin.

Fault: if too much combinations, it takes time, status windows auto displayed, system stopped.

I have run a serie of tests. I keep the command the same and modified only the mask from long to generate all combinations, to generate only few specific combinations

only then oclHashcat can find the password, see the final test with mask '1'?d?d?d?d?d?d?d at end of the log, password is found. In any other case when there is enough time for status window to come up. system will stop. Doing nothing. But not come out to command prompt

It is a bug with stdin.

Don't you use similar piped combination? Don't you think there is a bug with status window? or with stdin?

the logs is here

I am using linux, 11.10 64bit, ATI 12.4, oclHahscat+ 0.08
(07-13-2012, 04:45 AM)ntk Wrote: have found the fault.

I have to run with sudo

./mp64 ?d?d?d?d?d?d?d?d | sudo ./oclHashcat-plus64.bin -m 2500 Harkonen.hccap -o foundharkonen.txt

Nice of you to post back with your answer. Most people just leave the question hanging. Good to see a conclusion !