hashcat v3.00 Device not Found issue with Nvidia 970
(08-02-2016, 07:43 PM)Sololegends Wrote: Hello All,

I've been wracking my brain and scouring the Internet in an attempt to figure out this frustrating problem.

The Problem:
When trying to run hashcat v3.00 I'm met with
root@acomputer:~# hashcat -b
hashcat (v3.00) starting in benchmark-mode...

ERROR: clGetDeviceIDs() : -1 : CL_DEVICE_NOT_FOUND

Which seems to be a problem others have had, however, their solutions do not seem to work for my instance.

System Information:
-The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali) v2 GNU/Linux Rolling 64-bit (clean install at this point)
-Kernel v4.6.0-kali1-amd64
-intel 4770K
-Nvidia GTX 970
-64GBs of RAM (1866mhz)

What I've tried:
-I've updated and upgraded my The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali) (including dist-upgrade)
-I've gone through these Forum posts so far:
-I have gone through a clean installation of hashcat following the FAQ
-I ran through the "I may have the wrong driver installed, what should I do?"
-I've been through the troubleshooting in "What does the clGetDeviceIDs() -1 Error error message mean?"
-I've done clean installs of The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali) to start over

Current State:
Currently I have the version of Hashcat Directly from the site here.
Right now I have the official Nvidia drivers v367.27 installed, however, I've also tried v367.35 and v346.72.

And in checking my CL libraries I get:
root@acomputer:~# dpkg -S libOpenCL
ocl-icd-libopencl1:amd64: /usr/lib/x86_64-linux-gnu/libOpenCL.so.1.0.0
ocl-icd-libopencl1:amd64: /usr/share/man/man7/libOpenCL.7.gz
ocl-icd-libopencl1:amd64: /usr/share/man/man7/libOpenCL.so.7.gz
ocl-icd-libopencl1:amd64: /usr/lib/x86_64-linux-gnu/libOpenCL.so.1
ocl-icd-libopencl1:amd64: /usr/share/doc/ocl-icd-libopencl1/html/libOpenCL.html
Which, as far as I can tell, is right..

I've been at this for three days now and I'm at a loss for where to go next.. Any help you guys can provide will be greatly appreciated!


Any luck with this one? I am having the same issue as you and I also have tried all the steps suggested in other forums and by hashcat FAQ. I ran it on windows just fine but no luck with The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali).

Messages In This Thread
RE: hashcat v3.00 Device not Found issue with Nvidia 970 - by bootlegspider - 08-14-2016, 04:20 PM