ERROR: clGetPlatformIDs() -1001
This could be my fault but I am receiving this error "ERROR: clGetPlatformIDs() -1001" when trying to run the latest beta V0.08

Quote:ERROR: clGetPlatformIDs() -1001

I am using a ATI HD card.

I have installed the latest drivers and Catalyst 12.3

OpenGL Version
Catalyst Control Center Version
AIW/VIVO WDM Driver Version
AIW/VIVO WDM SP Driver Version

Can anyone suggest how I can fix it ?

Thank you.
which gpu is this?
#### Edit####

I have just come back to edit this post.

Please don't spend too much time on this atom as I have discovered that even my EWSA doesn't work with the new driver / Catalyst update.

I will probably just have to revert back to my old driver and v0.07


Oh the humiliation ! Ha ha! Big Grin

This is my cheap test computer with a HD5500 made by Sapphire. I haven’t dared to upgrade my cracking computer yet until I see this working.

Other details that may be of some use …

Primary Adapter
Graphics Card Manufacturer Powered by AMD
Graphics Chipset ATI Radeon HD 5500 Series
Device ID 68DA
Vendor 1002
Subsystem ID E163
Subsystem Vendor ID 174B
Graphics Bus Capability PCI Express 2.0
Maximum Bus Setting PCI Express 2.0 x16
BIOS Version
BIOS Part Number 113-5E1631SA-SF1
BIOS Date 2010/12/03
Memory Size 1024 MB
Memory Type DDR2
Core Clock in MHz 550 MHz
Memory Clock in MHz 400 MHz
Total Memory Bandwidth in GByte/s 12.8 GByte/s

As a test I reverted back to v 0.07 with the same error. This used to work on this computer before the AMD driver update. So to make it clear the driver / Catalyst update broke hashcat for me.

I think I know whats wrong.

The last working driver I had for this was...


The new one that didn't work was...

12-3_xp32_dd_ccc.exe (note missing _ocl)

I cannot however find 12-3_xp32_dd_ccc_ocl.exe on their site.
hmm whats going on there. i got serveral messages per pm, email and irc, since a few days.

maybe the new 12.3 is incompatible to oclHashcat-plus 0.07?
I've had mixed results with 12.3 using amd cards and .07 plus, some boxes work fine, some don't and have to be reverted to an old driver. Haven't been able to nail down a consistent pattern though.
(03-30-2012, 06:11 PM)atom Wrote: i got serveral messages per pm, email and irc, since a few days.

It's a shame people don't take the time to report possible bugs here on the forum instead of writing to you directly. This way everyone can see there is a potential problem and save a lot of time.

Anyway atom please don't alter anything with hascatplus as I am sure this is an AMD problem. As I mentioned before, EWSA doesn't work with the new drivers either so I doubt this has anything to do with hashcatplus.
Same error with last 12.6 !
I guess I have to go back to old drivers, and old versions of oclhashcat...
What a mess from amd (unless I'm wrong, I hope so).

Anyone else with these same problem ?