Hashcat 6.2.4 old AMD HIP version outdated
I have made a thread on this forum about AMD HIP errors in 6.2.3. Which is fixed now.
Hashcat 6.2.4 have new requirements, that I need AMD ROCm 4.3. ROCm need Ubuntu 20.4.02 (LTS).

I re-installed my whole system and now I get error about having a outdated AMD HIP versions.
AMD HIP version: 4.3.21300. Does it say somewhere where to download the newest AMD HIP version?
I thought that AMD HIP come with ROCm.
I didn't write much information, so I guess I can't get enough help.
I don't know why this happen to me. I had some issues with HIP before.

GPU: Radeon RX 580
Driver: ROCm
Driver version: 4.3-52
HIP version: 4.3.21300-5bbc51d8

OS: Linux
Distro: Ubuntu 20.4.02
Kernel: 5.8.0-43-generic

Hashcat version: 6.2.4

Hashcat -I:

There are some fundamental structural changes in HIP 4.4. These changes force us to support either the new HIP API or the old HIP API. Hashcat v6.2.4 is now rewritten to work with Hashcat as soon as AMD releases the new HIP API. You could say you could have waited for support for the new API until AMD really released it, but that only works if you have enough developers, but I work on this backend alone. Long story short, at the time of writing there's no way for end users to make use of the HIP API. Until they update to the new backend you need to stick to OpenCL backend.
I'm sorry that you work alone with the backend. I don't want to sound like fix this now. Maybe I did, if so I'm sorry. I will stick to the OpenCL backend. And thanks so much for taking your time to write this.