Old laptop - use hashcat on CPU
I have old Lenovo Y500 laptop with two GT 650M graphic cards which are not applicable to hashcat (too old).
However this laptop has quite good old CPU, i7-3630QM.

I wanted to try hashcat on CPU on this laptop and installed Intel deb packages from this site:


That is OpenCL Runtime for Intel CPUs.

I've downloaded all .deb files from newest release and run dpkg -i *.deb as root.

Everything went fine.

But hashcat still says the same error that the computer has no OpenCL Runtime...

Even if started with -D 1 or -d 1 options.

How can I make it work?
hashcat (v6.2.6) starting


ATTENTION! No OpenCL, HIP or CUDA compatible platform found.

You are probably missing the OpenCL, CUDA or HIP runtime installation.

* AMD GPUs on Linux require this driver:
  "AMDGPU" (21.50 or later) and "ROCm" (5.0 or later)
* Intel CPUs require this runtime:
  "OpenCL Runtime for Intel Core and Intel Xeon Processors" (16.1.1 or later)
* NVIDIA GPUs require this runtime and/or driver (both):
  "NVIDIA Driver" (440.64 or later)
  "CUDA Toolkit" (9.0 or later)
Package intel-opencl-icd is already installed. System is up-to-date Linux Mint 21 Vanessa.

I solved that installing "l_opencl_p_18.1.0.015.tgz" from Intel website.
(10-26-2022, 09:40 AM)marc1n Wrote: Always the same problem, but why search the forum as you can set up once again the same topic.

Don't be rude.

I've searched and I didn't found anything related.
Please share the link to the post that resolves that.