Device #3: ATTENTION! OpenCL kernel self-test failed.
So last night I was running hashcat just fine, this morning I am suddenly receiving

Device #3: ATTENTION! OpenCL kernel self-test failed.

OpenCL API (OpenCL 2.1 ) - Platform #2 [Intel(R) Corporation]
* Device #3: Intel(R) HD Graphics 630, 3200/6514 MB (1628 MB allocatable), 24MCU

Ive tried , reinstalling all the drivers, reinstalling opencl, I even tried using system restore to go back to an earlier date but nothing seems to be working. I tried following the directions at to no avail. The software they had me download to install the drivers seemed to do nothing at all and kept saying I need the pro version to do anything but look at issues.

My NVIDIA GeForce GTX 1070 seems to be functioning properly. I ran a bench test with no issues. However when I try to run a mask attack against a single MD5 hash it keeps giving me the above error then quitting hashcat. I believe some updates were installed automatically last night but why system restore wouldn't resolve that is beyond me.

I am at a total loss, most information Ive found seems to be directed toward my primary gpu not the onboard chip. Any help would be greatly appreciated. Ive already been at this over 5 hours now :[
You're wrong. this error is completely related to your onboard graphics integrated with your CPU. Just run your attack without using the onboard GPU/CPU using -D 2.

-D, --opencl-device-types      | Str  | OpenCL device-types to use, separated with commas    
# | Device Type
  1 | CPU
  2 | GPU
  3 | FPGA, DSP, Co-Processor
Sorry, thought thats what I said. Thanks that will be an excellent work around until I can get it figured out. Any idea why it would just stop working? I tried reinstalling the drivers via the intel site however I receive a message stating that I need to see my manufactures website, I then tried to install the drivers on dell's site but no luck. You wouldn't by chance know where I could find the appropriate driver?

In any case, thanks for the response. Will give that a try, not like the onboard gfx were adding much to the equation. Would still love to know a fix or why it just seemed to happen randomly. Like I said I ran a bunch of hashes last night, when it ended figured Id give my pc a chance to cool down. Came back in the morning tried to run some new hashes and received that message. Been struggling with it ever since, Thanks again.
Scroll down a bit until you hit the windows or linux downloads.
(12-17-2022, 03:42 AM)slyexe Wrote: Scroll down a bit until you hit the windows or linux downloads.

Thanks, but my system wont let me install from intel. It tells me to check my manufacturer. However the intel driver I get from Dell doesn't seem to be fixing the issue. Thanks anyway.

Still looking for assistance if anyone has any ideas.
show output of hashcat -I, and stick to the cpu part of your hybrid intel cpu/gpu (you have to combine -D and -d to achieve this)

dont use the intel graphics-part of your gpu as opencl is broken by default on intel integrated gpu's