Is it 'safe' to upgrade Ubuntu Server with hashcat?
First, I want to say thank you to whoever authored the tutorial on building a headless Ubuntu 12.04.1 server here:

That was almost exactly what I wanted to do (I would have preferred CentOS but I can suffer through Ubuntu).

I followed it and everything worked perfectly. I started out previously with a regular Ubuntu Desktop install (headless) but wrangling X and the default compiz install was a royal pain. A lot of bloat.

I now have a question about updating the Ubuntu Server installation. I understand that updating the Linux kernel will require me to reinstall the Catalyst drivers. Are there other 'hazards' associated with pulling apt-get updates? I thought I read on here somewhere that you should not use the newer Linux kernels; I wasn't clear on whether that was talking about beta stuff or newer production kernels. I use this particular machine for nothing other than hashcat experimentation and I currently only have AMD GPUs. It is connected to my network but the only traffic flowing to the Internet is whatever Ubuntu is doing autonomously.

I guess I'd like to confirm/learn the following:

1. Will updating the Ubuntu kernel require me to do anything special other than simply re-running the Catalyst install script?
2. Are there any package updates I should NEVER install or update? Or can I simply do an apt-get update and apt-get dist-upgrade and let it roll?

I'm just trying to avoid doing something that is irreversible or would require a lot of effort to undo. I'm happy to NOT update anything if that is the best option.

You're welcome.

The advantage of using an OS that has an SDLC and thus has long-term stable releases is that the software versions do not change. Even if you update the OS, the versions will all stay the same, you're just applying bug fixes and security backports.

So yes, you can safely update the OS. I set mine to automatically install updates. If you followed my guide and installed dkms, you shouldn't have to do anything after a kernel update. The kernel package's post-install hooks will trigger dkms to rebuild fglrx. You should not have to regenerate your xorg.conf or anything else.
(01-23-2013, 07:52 AM)epixoip Wrote: So yes, you can safely update the OS.

Indeed it worked just fine. Thank you sir, and thank you for the speedy reply.

And now a follow up stupid question to my first stupid question....

If and when I add an additional video card, will Hashcat (Catalyst) recognize it right away or do I need to re-kick something to see the new card? I wold try it myself but I don't have another card around here...yet.

hashcat only recognizes cards that the opencl platform tells it about. the opencl platform gets its information from the driver. the driver depends on x11. so you will need to generate a new xorg.conf whenever you add a card, remove a card, move a card to another pci-e slot, etc.
Well everything was working fine until today. I hadn't had a chance to do much for a couple weeks so I needed to upgrade hashcat-plus, Catalyst and Ubuntu.

I upgraded to the new Catalyst, performing the steps you provided here:
and everything was working fine with -plus 0.13 (thanks again).

I did an apt-get and noticed that there was a new version of lightdm and a new version of xserver, I don't know if that had anything to do with the price of corn in Nebraska. Now when I run hashcat-plus I get seg faults and core dumps. I did a search on the forum for this and found a couple problems but nothing like what I'm seeing. I can't run -plus at all.

I did notice that lightdm does not appear happy, I see this in syslog during boot:
init: lightdm main process (940) terminated with status 1

I can post more if it will help. I assume this is a known/simple issue; the problem is I don't know where to start. Do I want to reinstall Catalyst (and recreate the xorg.conf) or do I want to work with lightdm? Of course startx doesn't work and it appears X is not running. I checked the lightdm.conf file and and the xorg.conf from this morning and they both seem intact.

...maybe I just answered my own question. Why the heck isn't X11 running?
i'm confused.. you say you're using LTS, but then say a new version was available. with LTS releases, the versions are frozen -- there are no new versions of any packages. all that you receive are bug fixes.

anyway, to troubleshoot you need to start from the bottom of the stack. rm your xorg.conf, see if X11 will start. if it will, generate a new xorg.conf and see if X11 will start. the move on to lightdm, etc, all the way up the stack.
I think he did a release upgrade from 12.04 to 12.10
that would be quite tragic
I believe I am working again. For the record I'll post what I know here in the off-chance it might help someone else. A bit of a fail-ex on my part but it is working again.

(02-10-2013, 01:49 PM)epixoip Wrote: that would be quite tragic

Indeed, suckage might ensue. Fortunately, through dumb luck, I don't think that was the problem. At least not if I can trust motd:
Welcome to Ubuntu 12.04.2 LTS (GNU/Linux 3.2.0-37-generic x86_64)

As to the "new version" comment, I might have been using the wrong term. All I know is there were xserver and lightdm packages in the apt-get loadout:
xserver-xorg-core:amd64 (1.11.4-0ubuntu10.8, 1.11.4-0ubuntu10.11), xserver-common:amd64 (1.11.4-0ubuntu10.8, 1.11.4-0ubuntu10.11), lightdm:amd64 (1.2.1-0ubuntu1.1, 1.2.3-0ubuntu1), xserver-xorg-dev:amd64 (1.11.4-0ubuntu10.8, 1.11.4-0ubuntu10.11), liblightdm-gobject-1-0:amd64 (1.2.1-0ubuntu1.1, 1.2.3-0ubuntu1)

Anyway. /var/logXorg.0.log wasn't much help, at least not to me. If there was something critical/fatal buried in there it wasn't obvious. X just never started or if it did, it bailed immediately afterwards. Removing and rebuilding xorg.conf didn't seem to help at all.

As a penultimate attempt I thought it might be due to lack of a monitor or dummy plug on my video cards so I connected a monitor to both cards. The result was exactly the same as before.

So finally I did an organized deinstall and reinstall of Catalyst 13.1, exactly as epixoip showed in that other post (as I had done to go from 12.8 to 13.1). That worked.

Thanks again guys.
[BagLock reaching for the reserve handle....]
glad to hear it's working again.

yeah, we have experienced random issues, where sometimes catalyst just needs to be reinstalled. not a clue how it manages to fuck itself up. but a reinstall is quick and easy.