Catalyst 13.1 on Ubuntu 12.04

I have been trying to get the Catalyst 13.1 to work on Ubuntu 12.04 (LTS), 64-bit.

I have tried various ways of installing. Whenever the installation is successful and I reboot here is what happens.

It displays the Ubuntu logo and then suddenly the monitor goes blank and shows me the Symbols, "Hz" and "?" in a green box moving on the screen. After looking it up on Google, some suggest that it is related to out of frequency error and adjusting the Monitor Refresh rate might solve it.

However, this seems to happen only after I install the Catalyst 13.1 driver. I have not been able to install any other Catalyst Driver (older versions like 12.8) since they give an error with the linux kernel (post upgrade).

So, has anyone faced a similar issue while installing the Catalyst Driver and rebooting on Ubuntu?

Which linux kernel version works for you with Catalyst 13.1 and Ubuntu 12.04 LTS.

I currently have the linux kernel, 3.5.0-32-generic as my Linux Kernel (as a result of aptitude upgrade). The installation fails when I try the Catalyst 12.8 version. It does not give an error with 13.1 but after I reboot as I mentioned above, the display goes blank.

I have also tried editing the boot entry and use the "nomodeset" option while booting, but the error persists.

Please note that it all works good for me on Windows 7, 64 bit version on the same machine + Catalyst 12.8

GPU: ATI Radeon HD 5870

Help would be appreciated.
this isn't really hashcat related, it's more appropriate for the ubuntu forums, but i'll answer it anyway since i know the answer.

the issue is with the way xorg is detecting your monitor. your monitor probably does not report edid info, or if it does it must be reporting it incorrectly, which is causing xorg to select a mode that your monitor cannot handle.

the fix is to ssh in and hand-edit your xorg.conf to manually specify an appropriate modeline. you will need to calculate this yourself using the information found in your monitor's owner's manual.

this issue will not prevent you from running hashcat via ssh.
thanks epixoip, I will try to find more details.

Yeah, I know it is not related to hashcat and I have already tried asking on various Ubuntu forums including and none of them had any solution besides repeating the common steps.

What you have suggested, it is new to me. I will try it out and hope it fixes. I will also try to ssh and see if I am able to get oclhashcat-plus running Smile

PS: mine is an old CRT monitor. I wonder why it was working before the installation of the Catalyst Drivers. Does the Catalyst driver modify the xorg in a way that requires specific settings?

This monitor + Windows 7 x64 + Catalyst 12.8 works great Smile

8 year old monitor, let me see if I can find the manual Smile

If my monitor is reporting incorrect edidinfo then why does it display the Ubuntu blank purple screen for about 3 to 5 seconds before going blank?
That makes sense, old CRT monitors were notorious for either not supplying EDID information, or supplying bad EDID information.

The reason it only happens after you install Catalyst is because before you install Catalyst, you're using the generic Vesa driver, which only supports generic modes. It's the "this is guaranteed to work" driver. Once you install the proprietary driver, xorg learns of the specific modes your card can support, and thus tries to use an optimized mode. But since your monitor is giving xorg bad info, it ends up running in a mode your monitor can't actually support.

The reason you see the purple Ubuntu loading screen is because that screen is not displayed by x11, it's displayed on the framebuffer before xorg is started, via the vesafb framebuffer driver.
I think that you also forgot to write:

sudo amdconfig --adapter=all --initial -f

It should be done just after install, and only after this command you should reboot. Had similar problem on HD5970. Besides, you can login on failsafe mode, not only ssh.
@epixoip: thanks, I understand now Smile that is a good explanation.

@KT819GM: I did run that command post the installation of the Catalyst Driver. Only after that I rebooted and faced this issue.

now, I tried the options:

ssh - It appears that ssh is not installed by default on Ubuntu 12.04 and so though I am able to ping it from another machine in the same LAN, I am unable to SSH. I even ran Nmap against this IP and found 0 open ports (Ubuntu, by default has no open ports, I think).

So, ssh is not an option for me now as I need to first install openssh for which I need to get into Ubuntu.

failsafe - I think we need to go to this option from the Recovery Mode (listed in the GRUB menu). I did that and it presented me a Recovery Menu. I selected, failsafeX option from there to run in failsafe graphic mode.

It prompted me with: "Continuing will remount your filesystem in read/write mode and mount any other filesystem defined in /etc/fstab. Do you wish to continue?"

I selected Yes and now the screen goes just blank. There is no "out of frequency" box displayed either.

I even tried the following options by editing the GRUB menu for my current linux kernel:

1. replace "quite splash" with "nomodeset"
2. replace "quiet splash" with "xforcevesa"
3. replace "quiet splash" with "radeon.mode=0"

in all these cases, first a purple screen shows up for a few seconds, followed by a blank screen which shows the text "ubuntu login:" but screen goes blank again even before I can read it.

I wonder if there is any other way before I go ahead with a reinstallation.

I know these questions are specific to Ubuntu, but I am getting more help and suggestions here than the official Ubuntu Forums which were just suggesting me the usual steps.

Thanks Smile
replace "quiet splash" with "single". this will drop you to a root shell in single user mode. you can use this to install sshd, or you can just do everything from the local console. your pick.
Thanks epixoip Smile Your name always reminds me of Instruction Pointer (eip) Smile

It is working now. As you said, I had to edit the xorg.conf.

I added a new Display Subsection under the Screen section in xorg.conf and set the mode to 1024x768. It works good now.

oclhashcat-plus is working as well. I am wondering why the --gpu-temp-disable option is not working though. The fan speed is always at its peak when I run an attack (for instance, bruteforce).

I will create a new Topic for this.
turn your monitor upside-down and you will understand what my nick means Wink

glad to hear you got it all working!

even if you are using --gpu-temp-disable, the bios on the gpu will still control the fan if it detects the card is overheating, and brute forcing fast algorithms will heat a card up really quickly.