VCL CL_OUT_OF_HOST_MEMORY & (Mis)configuration
I'm working on setting up a small VCL cluster. I have three machines: two compute nodes and one broker. I am using VCL 1.22, oclHashcat-plus 0.15, and Catalyst 13.6. I get everything set up, run oclHashcat and get the following:

.oclHashcat-plus64.bin: /usr/lib/vcl/ no version information available (required by ./oclHashcat-plus64.bin)
oclHashcat-plus v0.15 by atom starting...

Hashes: 1 total, 1 unique salts, 1 unique digests
Bitmaps: 8 bits, 256 entries, 0x000000ff mask, 1024 bytes
Workload: 256 loops, 80 accel
Watchdog: Temperature abort trigger disabled
Watchdog: Temperature retain trigger disabled
Device #1: Tahiti, 3035MB, 925Mhz, 32MCU
Device #2: Tahiti, 3035MB, 960Mhz, 28MCU
ERROR: clCreateContext() -6

Per cl.h, -6 is CL_OUT_OF_HOST_MEMORY. I originally had 8GB in the broker. Upped it to 36GB and still got the same error. I believe that I have a configuration problem, rather than running out of RAM.

I set up the broker and compute nodes per the hashcat vcl wiki article. However, I have made two deviations from the instructions:
1 - The compute nodes are CentOS 6, rather than Ubuntu. I am repurposing existing machines. I've run OpenCL programs on them before and they work (and they don't have APP installed). The broker is Ubuntu 12.04.
2 - I'm running on a small, closed network, but there are other machines present (core servers and a dozen web VMs).

Going through other VCL posts, in this one it is mentioned that misconfigured networks can cause the broker to run out of memory. My compute nodes are sharing the network with other non-VCL servers. Could this be an/the issue? I don't know enough about how the VCL broker communicates with nodes.

Plus, there is the "/usr/lib/vcl/ no version information" line from the output. Is that to be expected?

Any feedback and advice is kindly appreciated.
the "no version information" line is innocuous and irrelevant, you may ignore it.

i've already reported this (as well as a couple other bugs) to MOSIX a few weeks ago. there is no workaround at the moment.
This is unfortunate.

Is there a combination of oclHashcat, VCL, and Catalyst that has worked well for others? Also, is there a place where I can get old versions of VCL?