Error cuCtxPopCurrent (cudaHashcat+64.exe)
I don't know if it's a bug..
When I run this command line :

cudaHashcat+64.exe -r rules\d3ad0ne_1.5K.rule -n 512  --gpu-loops 512  -m 1000  hash.txt "dics\full.txt"
cudaHashcat+ v0.03 starting...

ERROR: cuCtxPopCurrent() 999

And program exits.

Why ?
Then I put -n 256 instead of 512 and it works fine.

When I use a smaller rule (like leetspeak.rule) I am able to run the program with -n 512, without any error.
Does the rule file length acts on the -n parameter ?

Thank you.
What's your GPU ?
I cant test cudahc+ due to driver incompability, but I have an idea that your gpu is just overloaded, that's why -n 512 doesnt work.
play with it but dont oversize it
My GPU is GeForce 8400 GS, 239MB, 1400Mhz, 1MCU.
Not so good but works Smile
I will stay on "-n 256 --gpu-loops 512" it's fine for me.
I was able to reproduce the same problem by also putting extreme values:

-n 216 --gpu-loops 512

got the error cuCtxPopCurrent() 999

My cards in this case were a GTX260 and a GTS250.

Now another side effect and/or bug. If I put only --gpu-loops 1024. It works fine but end up missing passwords. Definitely don't want that. Maybe it already affects people without knowing...
hm, because of the status display it may look like it does not find all passes, but it does. look here:

Quote:root@erebus:~/oclHashcat+-0.02# /root/maskprocessor-0.63/mp64.bin ?d?d?d?d?d?d | ./cudaHashcat+64.bin x -o y
cudaHashcat+ v0.02 starting...

Hashes: 1000000
Bitmaps: 21 bits, 1048576 entries, 0x000fffff mask, 4194304 bytes
Rules: 1
Platform: NVidia compatible platform found
Device #1: GeForce GTX 580, 1535MB, 1700Mhz, 16MCU
Device #2: GeForce GTX 580, 1535MB, 1700Mhz, 16MCU
NOTE: gpu-accel auto-adjusted to: 1
Device #1: Kernel ./kernels/4318/m0000.sm_20.64.cubin
Device #2: Kernel ./kernels/4318/m0000.sm_20.64.cubin

Starting attack in stdin_mode...

p: 131072/1000000, cs: 1, cr: 0, cl: 6, rt: 10172.43ms, s: 12.89k/s
p: 262144/1000000, cs: 1, cr: 0, cl: 6, rt: 9839.46ms, s: 13.32k/s
p: 393216/1000000, cs: 1, cr: 0, cl: 6, rt: 9805.62ms, s: 13.37k/s
p: 524288/1000000, cs: 1, cr: 0, cl: 6, rt: 9909.23ms, s: 13.23k/s
p: 655360/1000000, cs: 1, cr: 0, cl: 6, rt: 9707.79ms, s: 13.50k/s
p: 786432/1000000, cs: 1, cr: 0, cl: 6, rt: 9855.99ms, s: 13.30k/s
p: 917504/1000000, cs: 1, cr: 0, cl: 6, rt: 10075.97ms, s: 13.01k/s

Started: Wed Feb 2 17:04:38 2011
Stopped: Wed Feb 2 17:05:55 2011

but its just a display problem. if you check the output file they are all found. its just missing a final display.

Quote:root@erebus:~/oclHashcat+-0.02# wc -l y
1000000 y
I put a lower number for -n and --gpu-loops parameter, and it works better.
maybe i should limit this to like 800 or so in next release
Hello Atom,

Please do look at providing some form of automation for the following -n value and --gpuloops-value options discussed above. I find as well depending on the digest length and type it can increase/decrease your attack. When in doubt I have left off the folloiwing 2 parameters and the speed has been descent.

I posted additonal information at the following thread:
no, they are there for a reason. for example if i want to play games or watch movies on the same card while i am cracking i need to lower these number to make room for additional calculations by 3rd applications.