Strange Performance Issue / R290X
I am facing a weird problem with the R290X performance on a newer Intel chipset. I hope I just did something wrong and I will quickly be pointed in the right direction Smile

I have used two test systems and two Radeon GPUs:
System #1
Motherboard: X8DTG-D (Supermicro)
Chipset: Intel 5520 (Tylersburg)
CPU: 2x Xeon E5645 @ 2.40 Ghz
RAM: 32 Gb @ 1333 Mhz
Slot: PCI-E 2.0 x16 [GEN2]

System #2
Motherboard: X9SRG-F (Supermicro)
Chipset: Intel C602 (Patsburg)
CPU: 1x Xeon E5-2630v2 @ 2.60 GHz
RAM: 32 Gb @ 1600 MHz
Slot: PCI-E 3.0 x16 [GEN3]

The Radeon GPUs are a 6990 and a R290X. Both have been used before with heavy loads and the hardware is perfectly ok. Hardware switch in the correct position, tuned with OD6, identical software on both machines.

O/S: Linux, Kernels tried: 3.2.0-4-amd64, 3.12-0-amd64
AMD Driver: fglrx 13.25.5 [Dec 6 2013]

I see the following performance measurements (oclHashcat -b -m1000):
On the System #1
6990 - 20048.4 MH/s
R290 - 17480.4 MH/s
On the System #2
6990 - 20123.4 MH/s
R290 - 14764.8 MH/s

I was quite surprised by the significantly lower performance of the R290X on the second system. The only differences I can spot is that on the System #2, the R290X is detected as PCI GEN3 - supposed to run faster if anything, and the BIOS is UEFI.

Any ideas?

Have already run --autofix on both systems (when using the R290X). Both perfectly identical, same init.

aticonfig --pplib-cmd "get activity"
Current Activity is Core Clock: 830MHZ
Memory Clock: 1250MHZ
VDDC: 1120
Activity: 98 percent
Performance Level: 2
Bus Speed: 5000
Bus Lanes: 16
Maximum Bus Lanes: 16

aticonfig --pplib-cmd "get activity"
Supported OD6.
Current OD6 Status is
Core Clock: 1000MHZ
Memory Clock: 1250MHZ
Activity: 100 percent
Performance Level: 0
Bus Speed: 8000
Bus Lanes: 16
Maximum Bus Lanes: 16

./od6config --autofix

Adapter 0: AMD Radeon R9 290 Series
New clocks : 1000 Mhz core, 1250 Mhz memory
New fan speed : 100%
New powertune value : 50
New target temp : 95

./od6config --get=clocks,fan,temp
Adapter 0: AMD Radeon R9 290 Series
Core (Mhz) Memory (Mhz)
Current Clocks : 1000 1250
Min Clocks : 1000 1250
Peak Clocks : 1000 1250
GPU Load : 0%
Fan Speed : 0% (0 RPM)
Current Temperature : 62 C
Target Temperature : 95 C
Quote:Fan Speed : 0% (0 RPM)

something is not right there. i wonder if that gpu is not broken. might consider RMAing it.
The fan reading is correct, we use the R290X without the case and without the fan. The case is 1U and there is a shroud in place to keep the airflow on the heatsink and we start the 4x dedicated loud case blowers when we use the card - keeps it at around 72-75 Celsius easily. I love this card, the heatsink blades are aligned to the card length (and not at a 90 degrees angle), which allows for the use of case fans.

Anyway, I have used the same card in the same setup (no fan) in both machines, and the performance diff is still there. I have checked with GPU case + fan and without them, no change in the measurements. So unfortunately this is not the reason ... could be something related to the chipset? PCI GEN3? Strange ...
ah ok, you're passively cooling it. cool Smile

i have no explanation for the speed difference, maybe it's just a lower binned chip.
yep, could be. but the 6990 has the same performance in both systems ... only it is gen2 and not gen3. i'll go play with the bios settings, hope for some dumb luck Smile
there's no performance difference between pcie gen2 and gen3 for hash cracking, and i can't think of any bios issues that would impact performance. so you're barking up the wrong tree.

it really sounds to me like you just drew the short straw with that card. i'd RMA it.
got your point, but it is the same physical card which has a better performance on system #1 and lower on system #2. I have some more R290X cards, I'll test with another one tomorrow and post the results - I expect pretty much the same. can't RMA both Smile
Different card tested, same result. Definitely something weird.