Mask Processor Fixed Character Problem
If mask processor is used piped to hashcat using the following...

mp32.exe -1 abcdef9876543210 ?1?1?1?1?1?1z | hashcat-cli32.exe -r sample.rule --stdout passlist.txt >> Rule_Result.txt

The "z" is not included in the output. I have also tried ...

mp32.exe -1 abcdef9876543210 ?1?1?1?1?1?1"z" | hashcat-cli32.exe -r sample.rule --stdout passlist.txt >> Rule_Result.txt
mp32.exe -1 abcdef9876543210 "?1?1?1?1?1?1z" | hashcat-cli32.exe -r sample.rule --stdout passlist.txt >> Rule_Result.txt

Neither of which work as expected for me.

The rule list simple prefixes letters ranging from abcdef9876543210 in 3 character columns in order that the final outcome is 10 characters long. I am only printing to a file now to see if it works as I intend to use this code directly to hashcatplus for WPA. I understood that I should add rules to hashcatplus to get the full benefit of GPU acceleration so this was an attempt to do that.

I just put a character "1" in the password list file to get it working in hashcat to file.

Any suggestions as to what I am doing wrong ?
Thank you.

I have just read the above and even I didn't understand it so I will try to explain this better.

My final intention is to pipe Mask-Processor to hashcatplus which uses a rule file then on to my hcap.

The password is 10 characters long.
The default character set is 0123456789abcdef.

The Z in the example above was so it stood out during testing.

I understand rules make better use of my GPU rather than directly using Mask-Processor. So, I decided to make Mask-Processor generate the last 7 characters and let the rule file in hashcatplus prefix every input with all the possibilities of 0123456789abcdef for the first 3 characters. Supposedly maximising the full use of my GPU.

I wanted to fix the last character in Mask-Processor to one of the characters in the list sequentially so I can split this job into 16 equal parts.

What I was trying or wanting to do was to actually see if my method worked. Hashcatplus has no way of printing to a text file or the screen so I didn't know if what I was doing was actually working. I tried to use hashcat to file to see what was happening.

When I did this I noticed that the fixed character was not being written to the text file so I assumed that this wouldn't be happening when I was running a brute force within hashcatplus. I just didn't want to be running this for a long time only to discover it was never being tested properly.

I wish there was some way hashcatplus could show you an example of what it was testing as the user presses the status button. It doesn't have to be the current password at the time of pressing but just an indication as to what is happening would be helpful.

I suspect my test failed because I needed to use a rule file with hashcat when writing to my test text file to see if the Mask-Processor + rule file thing worked.

Is there anyway I can test to see if this is happening when running Mask-Processor + hashcatplus + rule file direct to my hcap ??