Problems with the encodings of dictionaries ...
Help please understand the hacking of passwords when working with various encodings of dictionaries...

I created a RAR archive with a password in Turkish - abaküsçü

Got a hash of the password - $RAR3$*0*83xxxx04c276xxd0*840fxxxxxxafc0a5xxxxb31053xxxx41

Also I have a dictionary in which there is a given password in the UTF-8 encoding (turkish.dic).
I ran cracking in the windows console with different options, for example:

hashcat64 -m 12500 -a 0 $RAR3$*0*83xxxx04c276xxd0*840fxxxxxxafc0a5xxxxb31053xxxx41 turkish.dic


hashcat64 -m 12500 -a 0  --encoding-from=utf-8 --encoding-to=866 $RAR3$*0*83xxxx04c276xxd0*840fxxxxxxafc0a5xxxxb31053xxxx41 turkish.dic

But not successfully((

What's the problem, what am I doing wrong?

[edit: all hashes masked by philsmd]

Attached Files
.png   screen_run1.png (Size: 38.91 KB / Downloads: 4)
.png   screen_run2.png (Size: 38.32 KB / Downloads: 3)
You are not allowed to post hashes here, you get banned for breaking the forum rules.

For what regards the problem with encoding: you need to use the correct encoding, in this case it is ISO-8859-9:

hashcat -m 12500 --encoding-to ISO-8859-9 hash.txt dict.txt
Thank you so much!
what are the parameters for the Cyrillic alphabet?

I created a RAR archive with a password in Russian - я

I have a russian dictionary in the UTF-8 encoding.
hashcat -m 12500 --encoding-to ISO-8859-5 hash.txt dict.txt

No result (((
russian passwords could also be encoded with CP1251 or KOI8-R etc.
Pro tip: there are some charsets shipped with hashcat (see for instance the charsets/standard/Russian folder under your extracted hashcat folder)... or just search with your preferred search engine what the possible/standard/default encodings for a specific language is.
I created a RAR archive with a password in Russian - я (len of password - 1)
I tried (GPU GTX 1080 and GTX980):

hashcat -m 12500 -a 3 hash.txt ?b


hashcat -m 12500 -a 3 hash.txt ?b?b
but the password was not found((

When I created MD5 hash with same password - я, password was found successful..