OpenCL not throwing an error or showing OpenCL devices
Hey, i'm having a few issues getting OpenCL to even give me an output let alone run. Usually if OpenCL will give an error message of some kind however it's just running and showing absolutely nothing.

For context i've just upgraded from Intel (6700k) to AMD (Ryzen 2700x), so i've removed all the intel openCL SDK, done DDU on the display drivers and manually removed the OpenCL.dll files and then reinstalled the Nvidia driver and the cuda toolkit (which containts the OpenCL toolkit)

The attached screenshots are from CLinfo.exe and Hashcat.

Is there anything im missing? as far as the wiki says for nvidia you should just install the graphics drivers (which i've tried before installing the cuda toolkit as well)

Any help would be appreciated before i do a full windows reinstall lmao
remove anything that has "cuda" or "sdk" in its name and make sure there are no leftovers. All you need is the intel opencl runtime and the standard nvidia driver.
I tried this, removed everything to do with cuda and all the SDKs i have installed and no luck. Even went through the driver setup on the wiki, removing the openCL dlls.

Could using the latest nvidia drivers be the issue? cause it says anything after 367 and i think we're on 417?

Looking at this stage like a fresh install of windows is going to be needed.
update fresh install of windows fixed it. I assume the move from intel to amd and left over opencl install is probably the cause.