Doing nothing when trying to output potfile
I have cracked hashes with the --username arg originally that had format (user : pass : salt) and the pot file has the cracked hashes in (hash : salt : plaintext) and I have the original hash file. So I am trying to output them into a seperate file and combine them back with usernames (user : plaintext) using command
hashcat64.exe -m 120 --potfile-path=filename.pot --username --show -o "outfilehere" --outfile-format=2 "originalhashfilehere"


Like I have always used but it just seems to launch and then sit there, doesn't error/doesn't end/just sits open...
Usually I launch this and its completed in 20 seconds tops?

Any ideas?

Just to add I am using latest version (5.1.0) on windows 10 - I used to use 3.1.0 and that command worked fine to output them has something changed?
how large is your hash file ? How many hashes do you have ?

Did you try to test with a subset of the whole hashes (a much smaller hash file) ?

As far as I know, the combining of hashes and usernames is quite tricky/complicated/complex because the potfile doesn't store the information about usernames and the hashes could be assigned to muliple users (at least if unsalted or a very small salt)...
that said, we had some fixed performance issues before and it's not excluded that we introduced a new problem with newer versions of hashcat... we need to know if it has to do with the amount of hashes and how bad it is depending on the amount of users/hashes.

Could you please try some subset and give some numbers ? Thank you very much
Around 1.1 million original hashes with users give or take and the cracked amount is around 900k, I copied the pot file to older version of hashcat I used to use (3.1.0) and executed the exact same command line arguments and it worked within 30 seconds
Thanks. Could you test also with the latest hashcat version but with much fewer hashes ? Is is still not responding (doing anything) then ? How slow is it with for instance just 10000 hashes ?