Hashcat Segmentation Fault
Hello, I am in need of assistance. I have a Lenovo laptop with Ubuntu installed and I need to recover a WPA/PSK password for a particular access point. I am a newbie when it comes to hashcat, so I followed one of the several guides online to use Hashcat to find a WPA passkey. As far as I know, my internet card in this laptop is enough to capture a PMKID packet, and my computer has fast enough hardware (An i7-620M CPU with Intel HD Graphics (Ironlake) and 4GB of RAM.) No matter what I do though, I can't get hashcat to work. I keep getting a Segmentation Fault error.

This is what I'm inputting into the terminal:

hashcat -m 16800 galleriaHC.16800 -a 0 --kernel-accel=1 -w 4 --force 'topwifipass.txt'

And I have already tried running it as root, no difference. I checked to ensure I have OpenCL runtime for Intel CPUs and HD Graphics, and I checked for the intel microcode for linux and I have it. What is going wrong here? Is there any easy way to debug this or see what's stopping it?
Did you add  --force because of an online guide or because hashcat gave some errors? This usually indicates you are ignoring advice the hashcat program is giving you to solve your problem.

Can you run hashcat with just hashcat -b and copy & paste the total output here?
my bet is that pocl and/or mesa are again the culprit. uninstall them

btw: cracking with a laptop is not a good idea (throttling and cooling issues, destroying the hardware because they are not designed for this type of load)
Okay DanielG, I tried your command and this is the output.

hashcat (v5.1.0) starting in benchmark mode...

Benchmarking uses hand-optimized kernel code by default.
You can use it in your cracking session by setting the -O option.
Note: Using optimized kernel code limits the maximum supported password length.
To disable the optimized kernel code in benchmark mode, use the -w option.

* Device #1: Not a native Intel OpenCL runtime. Expect massive speed loss.
            You can use --force to override, but do not report related errors.
No devices found/left.

Started: Thu May 30 23:16:25 2019
Stopped: Thu May 30 23:16:27 2019

It says "Not a native Intel OpenCL runtime". But I installed OpenCL runtime for intel in the apt package reserve from Ubuntu after hashcat wouldn't run way before I wrote this post.

Thank you both for your responses.

Philsmd, what is pocl and/or mesa and how can they be a culprit? I realized after looking up several forums that a laptop might not be the best thing to use hashcat with, but I would like to try it anyway just in case it might work. If my Lenovo starts getting hot, I'll terminate the command before any damage is done.