Hashcat not working on debian with r9 390 and AMDGPU drivers.
I have problem with hashcat for 3 days now. I installed newest clean debian release and then I downloaded newest hashcat. It does not want to detect my R9 390 and I did everything correctly (I belive).

Here are some outputs:

hashcat --version


lspci -k | grep -EA3 'VGA|3D|Display'

01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Hawaii PRO [Radeon R9 290/390] (rev 80)
        Subsystem: Gigabyte Technology Co., Ltd Hawaii PRO [Radeon R9 290/390]
        Kernel driver in use: amdgpu
        Kernel modules: radeon, amdgpu

hashcat -b

hashcat (v5.1.0-1181-gc34fcabb) starting in benchmark mode...

Benchmarking uses hand-optimized kernel code by default.
You can use it in your cracking session by setting the -O option.
Note: Using optimized kernel code limits the maximum supported password length.
To disable the optimized kernel code in benchmark mode, use the -w option.



Do you have some ideas why it does not want to work? Drivers are installed,hashcat is updated.
on linux you need to install rocm for AMD cards
Ok So i installed it following this guide:
Now when I start hashcat it just waits:

hashcat -I
hashcat (v5.1.0-1181-gc34fcabb) starting...

Also when I run:


it returns:

Number of platforms: 1
Platform Profile: FULL_PROFILE
Platform Version: OpenCL 1.1 Mesa 18.3.6
Platform Name: Clover
Platform Vendor: Mesa
Platform Extensions: cl_khr_icd

Platform Name: Clover
ERROR: clGetDeviceIDs(-1)
you probably need to remove the mesa opencl runtime.
Ok i removed mesa. Now clinfo shows info about my cpu but not about GPU.
Also hashcat shows:
No devices found/left.
that probably means rocm isn't correctly installed
opencl-amd, rocm-opencl-runtime. That's arch, but you probably will find equivalent.


Still, amd is pretty much broken for hashcat(I don't know why it is advertized that it is usable). Some self-tests(some hashes) will fail and if you disable self-test you won't get all passwords(or at all).