Is my config too weak ?
Hi everyone!

TL;DR when I enter
hashcat64.bin -m 0 -b
, I get an "Insufficient memory available ADL_Adapter_AdapterInfo_Get(): -3" error. I do realise this computer I'm using is not a racing rig, but it's all I have with me at the moment. Is this simply it or am I missing something ?

Now, if you guys have time to read.

Let me start by saying I had never heard of Hashcat or mask attacks before tonight. I landed here, like many others before me, driven by sheer curiosity, the sole will to learn and develop myself as an individual, and absolutely not because I'm a dumbass who locked himself out of his password manager.

Please understand me : I did some research on my own before coming to bother you. My CS illiteracy is that serious that I did not know what a CLI was before tonight. Yet I did install hashcat, run the thing, found out about the commands and the concepts behind them. Where I'm going with this, is I feel like I've really tried my best. Yet I couldn't get any command to run. After a while, I tried the built-in benchmarking command, which resulted in an error message, the same I'm getting since the beginning, really :

Insufficient memory available

ADL_Adapter_AdapterInfo_Get(): -3

Now here's the thing. I'm home, but my actual (beloved) rig isn't. All I have on hands at the moment is a laptop with no GPU and a somewhat modest AMD CPU. Which leads me to my question : am I doing something wrong, or is there a minimal, required configuration, under which hashcat simply won't run ?

Thanks a bunch for your help!
It would certainly be useful to list your hardware if you want an opinion on that. Since you are using a laptop with CPU chances are pretty high it's not suitable for hashcat. (and running hashcat on laptops is not recommended anyway)