[SOLVED] 'inconsistency in registered CommandLine options' on Ubuntu 19.10
Hi all!  I'm trying to run hashcat 5.1.0 on a new Ubuntu 19.10 system.

The system is a fresh 19.04 install that was immediately upgraded to 19.10 after the install.  When I start hashcat, I get the following error message:

: CommandLine Error: Option 'limited-coverage-experimental' registered more than once!

LLVM ERROR: inconsistency in registered CommandLine options

I get the same error with the Ubuntu package for Hashcat, the published binary, and the binary built from 5.1.0 sources.

I understand from reading about other users having the same issue with other packages that statically linking with LLVM could be a solution.  So my questions are:
1) Is there a known solution to the above error?
2) What is the proper way to statically link hashcat with LLVM?

What's your command line?
I have an X1 Thinkpad with Intel graphics.  This command triggers the error message consistently:
hashcat -b -m 2500 --force
You are using --force. Please read the error warnings that are displayed when using --force.

You have enabled --force to bypass dangerous warnings and errors!
This can hide serious problems and should only be done when debugging.
Do not report hashcat issues encountered when using --force.
I assume this is the OpenCL kernel compilation by the driver failing while running hashcat ?
That only means that the driver itself is not compatible with your system (linux version). maybe see if the driver supports that specific version of the operating system and compile environment (llvm in this case)
Two things:
1) It was almost certainly a dist-upgrade problem.  I did a fresh install directly to Ubuntu 19.10 and the error went away.
2) I still have to use --force, since Intel Graphics is listed as broken:
* Device #1: Intel's OpenCL runtime (GPU only) is currently broken.
            We are waiting for updated OpenCL drivers from Intel.
            You can use --force to override, but do not report related errors.

Perhaps I should see if building the Intel OCL from the latest git sources will give me a non-broken device?