Bitcoin wallet.dat hash - token length exception
I can't figure out what's going wrong when trying to match a password with a Bitcoin Core wallet hash.

I have tried Googling and read some posts here, but so far no luck.

Here is what happens:

james@john:~/john/run$ hashcat -a 0 -m 11300 ~/wallet_hash.dat ~/wordlists/words.txt
hashcat (v5.1.0) starting...

* Device #1: Not a native Intel OpenCL runtime. Expect massive speed loss.
            You can use --force to override, but do not report related errors.
OpenCL Platform #1: The pocl project
* Device #1: pthread-Intel(R) Xeon(R) CPU, skipped.

OpenCL Platform #2: Intel(R) Corporation
* Device #2: Intel(R) Xeon(R) CPU, 4003/16013 MB allocatable, 4MCU

Hashfile '/home/james/wallet_hash.dat' on line 1 ($bitco...cb87989a39ef71$60692$2$00$2$00$2): Token length exception
No hashes loaded.

Started: Mon Jan 18 02:46:38 2021
Stopped: Mon Jan 18 02:46:38 2021

Here is the hash: $bitcoin$64$9269f788d7bcecd411d95cc222c9f0cdf7ebfc6fa33847607f7b8c1338a2c3f8$16$10cb87989a39ef71$60692$2$00$2$00$2

I created the hash with from Openwall's John the Ripper repo.

Any clues on why this hash isn't being recognised as a valid wallet.dat hash?

Thanks for any help!
Curiously, this worked fine on my laptop with the latest version of hashcat.

It didn't want to work at all on a Google compute instance. I tried the Ubuntu 20.04 LTS version, 5.1.1, and the latest version from hashcat, both of which gave errors.

With the latest version, clCreateContext(): CL_DEVICE_NOT_AVAILABLE. hashcat freezes up when running ./hashcat -I and doesn't stop. I have to send CTRL+C to stop it.
You are missing a $00 in the end after that $2 at east in my hashes there is that always..
(01-18-2021, 09:06 AM)vicious1 Wrote: You are missing a $00 in the end after that $2 at east in my hashes there is that always..

Or remove the 2 on the end. It looks like the last number 2 should not be there.