OpenCl kernel self-test failed when using any version later than v4.2.1 !!
#29
(02-26-2020, 11:58 AM)philsmd Wrote: so you say that you are pressing "s" and the output never appears ?


Yes, it just prints s.
(02-26-2020, 11:58 AM)philsmd Wrote:

Does this happen "only" in -a 0 ?


Just tried -1 and -3 its the same
(02-26-2020, 11:58 AM)philsmd Wrote:

I would suggest that you re-install the drivers following this tutorial https://hashcat.net/faq/wrongdriver

and using driver fusion or DDU (display driver uninstaller) to remove all older/wrong libraries/OpenCL Runtimes etc.



I kinda tried that already Sad I could have missed something, but the -benchmark option is working for most hashes, doesn't this validate the driver somehow?

$ ./hashcat.exe --benchmark
hashcat (v5.1.0-1701-g669619c1) starting in benchmark mode...

Benchmarking uses hand-optimized kernel code by default.
You can use it in your cracking session by setting the -O option.
Note: Using optimized kernel code limits the maximum supported password length.
To disable the optimized kernel code in benchmark mode, use the -w option.

OpenCL API (OpenCL 2.1 AMD-APP (3004.8)) - Platform #1 [Advanced Micro Devices, Inc.]
=====================================================================================
* Device #1: Bonaire, 1984/2048 MB (1523 MB allocatable), 12MCU

Benchmark relevant options:
===========================
* --optimized-kernel-enable

Hashmode: 0 - MD5

Speed.#1.........:  3444.9 MH/s (57.23ms) @ Accel:1024 Loops:256 Thr:64 Vec:1

Hashmode: 100 - SHA1

Speed.#1.........:  1114.8 MH/s (89.08ms) @ Accel:512 Loops:256 Thr:64 Vec:1

Hashmode: 1400 - SHA2-256

Speed.#1.........:  480.2 MH/s (51.24ms) @ Accel:256 Loops:128 Thr:64 Vec:1

Hashmode: 1700 - SHA2-512

Speed.#1.........:  100.5 MH/s (61.03ms) @ Accel:16 Loops:512 Thr:64 Vec:1

Hashmode: 22000 - WPA-PBKDF2-PMKID+EAPOL (Iterations: 4095)

Speed.#1.........:    56815 H/s (53.28ms) @ Accel:256 Loops:64 Thr:64 Vec:1

Hashmode: 1000 - NTLM

Speed.#1.........:  5477.3 MH/s (72.21ms) @ Accel:1024 Loops:512 Thr:64 Vec:1

Hashmode: 3000 - LM

Speed.#1.........:  3235.6 MH/s (60.46ms) @ Accel:256 Loops:1024 Thr:64 Vec:1

Hashmode: 5500 - NetNTLMv1 / NetNTLMv1+ESS

Speed.#1.........:  3025.1 MH/s (65.39ms) @ Accel:256 Loops:1024 Thr:64 Vec:1

Hashmode: 5600 - NetNTLMv2

Speed.#1.........:  231.9 MH/s (53.09ms) @ Accel:256 Loops:64 Thr:64 Vec:1

Hashmode: 1500 - descrypt, DES (Unix), Traditional DES

Speed.#1.........:  123.1 MH/s (49.33ms) @ Accel:8 Loops:1024 Thr:64 Vec:1

Hashmode: 500 - md5crypt, MD5 (Unix), Cisco-IOS $1$ (MD5) (Iterations: 1000)

Speed.#1.........:  1329.0 kH/s (71.67ms) @ Accel:512 Loops:250 Thr:64 Vec:1

Hashmode: 3200 - bcrypt $2*$, Blowfish (Unix) (Iterations: 32)

Speed.#1.........:    1933 H/s (47.11ms) @ Accel:2 Loops:16 Thr:8 Vec:1

Hashmode: 1800 - sha512crypt $6$, SHA512 (Unix) (Iterations: 5000)

Speed.#1.........:    11742 H/s (51.11ms) @ Accel:16 Loops:256 Thr:64 Vec:1

Hashmode: 7500 - Kerberos 5, etype 23, AS-REQ Pre-Auth

Speed.#1.........: 27008.6 kH/s (56.77ms) @ Accel:64 Loops:32 Thr:64 Vec:1

Hashmode: 13100 - Kerberos 5, etype 23, TGS-REP

Speed.#1.........: 28450.5 kH/s (54.04ms) @ Accel:64 Loops:32 Thr:64 Vec:1

Hashmode: 15300 - DPAPI masterkey file v1 (Iterations: 23999)

* Device #1: ATTENTION! OpenCL kernel self-test failed.

Your device driver installation is probably broken.
See also: https://hashcat.net/faq/wrongdriver

Speed.#1.........:    9686 H/s (53.30ms) @ Accel:256 Loops:64 Thr:64 Vec:1

Hashmode: 15900 - DPAPI masterkey file v2 (Iterations: 12899)

Speed.#1.........:    1629 H/s (73.28ms) @ Accel:8 Loops:256 Thr:64 Vec:1

Hashmode: 7100 - macOS v10.8+ (PBKDF2-SHA512) (Iterations: 1023)

Speed.#1.........:    20244 H/s (59.41ms) @ Accel:8 Loops:255 Thr:64 Vec:1

Hashmode: 11600 - 7-Zip (Iterations: 16384)

Speed.#1.........:    56363 H/s (93.58ms) @ Accel:32 Loops:4096 Thr:64 Vec:1

Hashmode: 12500 - RAR3-hp (Iterations: 262144)

Speed.#1.........:    6554 H/s (57.77ms) @ Accel:8 Loops:16384 Thr:64 Vec:1

Hashmode: 13000 - RAR5 (Iterations: 32799)

Speed.#1.........:    6169 H/s (61.41ms) @ Accel:256 Loops:64 Thr:64 Vec:1

Hashmode: 6211 - TrueCrypt RIPEMD160 + XTS 512 bit (Iterations: 1999)

Speed.#1.........:    43446 H/s (68.63ms) @ Accel:128 Loops:64 Thr:64 Vec:1

Hashmode: 13400 - KeePass 1 (AES/Twofish) and KeePass 2 (AES) (Iterations: 24569)

Speed.#1.........:    11498 H/s (88.44ms) @ Accel:256 Loops:128 Thr:64 Vec:1

Hashmode: 6800 - LastPass + LastPass sniffed (Iterations: 499)

Speed.#1.........:  389.4 kH/s (47.99ms) @ Accel:128 Loops:124 Thr:64 Vec:1

Hashmode: 11300 - Bitcoin/Litecoin wallet.dat (Iterations: 200459)

Speed.#1.........:      596 H/s (52.00ms) @ Accel:128 Loops:64 Thr:64 Vec:1

(02-26-2020, 11:58 AM)philsmd Wrote:

Do you use a remote shell to connect to this system ? If yes, try without the remote connection (ssh/RDP).


no

(02-26-2020, 11:58 AM)philsmd Wrote:

what is the output of hashcat -I



$ ./hashcat.exe -I
hashcat (v5.1.0-1701-g669619c1) starting...

OpenCL Info:
============

OpenCL Platform ID #1
  Vendor..: Advanced Micro Devices, Inc.
  Name....: AMD Accelerated Parallel Processing
  Version.: OpenCL 2.1 AMD-APP (3004.8)

  Backend Device ID #1
    Type...........: GPU
    Vendor.ID......: 1
    Vendor.........: Advanced Micro Devices, Inc.
    Name...........: Bonaire
    Version........: OpenCL 2.0 AMD-APP (3004.8)
    Processor(s)...: 12
    Clock..........: 1060
    Memory.Total...: 2048 MB (limited to 1523 MB allocatable in one block)
    Memory.Free....: 1984 MB
    OpenCL.Version.: OpenCL C 2.0
    Driver.Version.: 3004.8

(02-26-2020, 11:58 AM)philsmd Wrote:
do you have a OpenCL compatible CPU installed (and maybe the runtime too ?) ?
it seems so?
Reply


Messages In This Thread
RE: OpenCl kernel self-test failed when using any version later than v4.2.1 !! - by frnck - 02-27-2020, 08:00 AM