Running Hashcat on multiple GPU rigs
I am trying to use Hashcat on with dizcza/docker-hashcat:latest image. 

I can successfully run everything on one GPU rig - it can have just 1 GPU or 8 GPUs. No issues with the quantity as long as they are a part of the same rig. 

However, if I rent more rigs, say 2 x GPU rigs with 8 GPUs in each, I am unable to run the task parallelly on both units.

Meaning, I would have to start the task separately on the second unit, which would be running independently from the first rig. 

I tried using the "Host 1 has 8 GPU" and "Host 2 has 8 GPU" command but it does not synchronize the two rigs. 

Does anyone know which command would I need to use to synchronize multiple GPU rigs on
hashcat has no built-in multi-chassis support (other than --skip/--limit and/or loose collaboration with 'brain' mode).

If you want automated distribution of a single attack across multiple chassis, you have to either use one of the above, or a framework like hashtopolis.
Hi Royce. Thanks for your prompt response. That makes sense. I will try Hashtopolis.
Hi Royce. I was able to configure the hashtopolis server in ubuntu.

I have enabled remote access to the server from any IP using % and to connect to, I am using Docker image milz0/hashtopolis-hashcat-vast with my URL and Voucher details.

However, I am still unable to see the rented GPUs under "Show Agents" in hashtopolis. I have created the Task with the list of hashes correctly.

I am thinking that the problem could be in my URL as it is essentially my IP address.

For example, the URL shows http://10.x.x.x/api/server.php

I have also tried disabling the "bind-address" with # and have enabled traffic on port 3306 on my firewall.

Do you know what I might be missing?

Check webserver logs
Hi Atom. I was eventually able to figure it out after several hours. Thanks