Trouble getting started
When I run hashcat I get the following error:

C:\reskit\oclHashcat-plus-0.09>cudaHashcat-plus32.exe -t 32 -a 7 example0.hash ?a?a?a?a example.dict
ERROR: No NVidia compatible platform found

I have installed the latest forceware drivers v306.23:

Name NVIDIA GeForce 9800 GTX/9800 GTX+
PNP Device ID PCI\VEN_10DE&DEV_0612&SUBSYS_C8733842&REV_A2\4&309465BD&0&0008
Adapter Type GeForce 9800 GTX/9800 GTX+, NVIDIA compatible
Adapter Description NVIDIA GeForce 9800 GTX/9800 GTX+
Adapter RAM 512.00 MB (536,870,912 bytes)
Installed Drivers nvd3dum.dll,nvwgf2um.dll,nvwgf2um.dll
Driver Version
INF File oem41.inf (Section008 section)
Color Planes Not Available
Color Table Entries 4294967296
Resolution 1920 x 1080 x 60 hertz
Bits/Pixel 32
Memory Address 0xF6000000-0xF6FFFFFF
Memory Address 0xE0000000-0xEFFFFFFF
Memory Address 0xF4000000-0xF7FFFFFF
I/O Port 0x0000B000-0x0000BFFF
IRQ Channel IRQ 16
I/O Port 0x000003B0-0x000003BB
I/O Port 0x000003C0-0x000003DF
Memory Address 0xA0000-0xBFFFF
Driver c:\windows\system32\drivers\nvlddmkm.sys (, 10.29 MB (10,790,760 bytes), 9/18/2012 8:33 AM)

And I have the following NVIDIA software installed:

DisplayName REG_SZ NVIDIA Stereoscopic 3D Driver
DisplayName REG_SZ NVIDIA 3D Vision Driver 306.23
DisplayName REG_SZ NVIDIA Control Panel 306.23
DisplayName REG_SZ NVIDIA Graphics Driver 306.23
DisplayName REG_SZ NVIDIA 3D Vision Controller Driver 306.23
DisplayName REG_SZ NVIDIA PhysX System Software 9.12.0213
DisplayName REG_SZ NVIDIA Update 1.8.15
DisplayName REG_SZ NVIDIA Install Application
DisplayName REG_SZ NVIDIA Update Components
DisplayName REG_SZ NVIDIA PhysX

I am running on Windows 7 32 bit. Is there anything else I need to do?
No, the driver is OK, and you GPU is OK, too, its listed here:

Have you tried any other CUDA app?
Thanks for the reply. I worked out the issue. I was trying to access the PC using a remote desktop connection and via RDP hash cat was unable to access the drivers. Once I VNC'd in instead it worked just fine.
Interesting how such useless detail like rdp was forgotten to mention when asking for help. Anyway