It never stops running
I try to crack a phpbb3 hash but this is my very first time and it looks complicated to me.
I tried to do something but I wait some hours and nothing happened.

But I'm not even sure I use it like it must be used ! Although I swear I look for tutorials... I found some, but I didn't understood them so... Here I am

Here is what I did:
I opened cmd
I went to the oclHashcat directory
I put:
cudaHashcat-plus32.exe -m 400 mdpcry.txt -o mdpdec.txt

And it never ends.
The password crypted is in mdpcry.txt and I want the result to be written in mdpdec.txt
I read that I should use rules, dictionnary, things like that, but I have no idea which ones I should use!
If it can help Hashcat, I have an example of an another password crypted (with the same "key") and not crypted, but I don't know if it's helpful, and if it is I don't know how.

I really wish somebody will have the patience to help me, because it looks like I spent the whole day trying to do something that is not that hard...

PS : I also read somewhere that using oclHashcat-plus may be dangerous for the computer ? Because my laptop used to get very hot, but since I cleaned it and add a little fan under it.
you can see the progress when hitting "s"
you are also missing a wordlist, or mask
Thanks for answering Smile

Well I have an other problem : I can't iterrupt it when it's running !
I tried to hit "p" to pause it, but it didn't work, like if hashcat didn't care about my keyboard...
Maybe I'm running it wrong, but if I try to open cudaHashcat-plus32.exe directly, it open a command window that close up immediatly !
The way I described in my first post is the only way to use it I found.

And radix I'll try it later but I'll need to search what are wordlists and masks because I didn't understande that too (what they are, how I must choose them, how I put them in the command...)
If you have a link that can help be it will be extremly nice !

Sorry if my english is bad but in my country it's the morning and I slept for a very short time :/

We need the below info:

What NVIDIA GPU your running.
What NVIDIA ForceWare your running.

Note: for cudaHashcat-plus - NV users require ForceWare 304.51 or later.
No, its as radix said. He is missing a dictionary / mask so oclHashcat-plus went into stdin mode. Thats why it doesnt offer keyboard input
I use "Nvidia GeForce with CUDA - GT 330M" but I have no idea about ForceWare... Where can I see if I have it ? And if I don't, how can I get it ?

And indeed atom, it shows "stdin mode" ! But I still don't understand why I need a dictionnary : what if the password isn't a word, but just a mix of letters and numbers that makes no sense ?
And what does a "mask" stand for ?
(01-29-2013, 02:51 PM)carandache Wrote: But I still don't understand why I need a dictionnary : what if the password isn't a word, but just a mix of letters and numbers that makes no sense ?
And what does a "mask" stand for ?

"dictionary" is a misnomer, it doesn't literally mean you need a dictionary. "wordlist" is more accurate. there are lots of wordlists for download at

if the password is random or cannot be found through other means, then you will do a mask attack. see

there are lots of other attack modes as well, not just these two. have a look at the wiki
Ok so this time I tried to use the mass attack (instead of the dictionary because even if it's more a wordlist, I don't think a word will be use because the password souldn't be english)
So I wrote this :
cudaHashcat-plus32.exe mdpcry.txt -m 400 -1 ?l?u?d ?1?1?1?1?1?1 -o mdpdec.txt
But it tells me : "?1?1?1?1?1?1: No such file in directory"
I thought I wasn't using the right order so I placed the elements differently but it keeps happening...
I deduce I misunderstood how to use the mass attack.
And furthermore, if the password is longer than 6 characters, I'll have to try again and again ?

(In case of you'll begin to loose your patience, I remember that this is my very first time I'm using hashcat...And also the windows commands! So pleaaase don't give up Sad )
It's because you're missing -a 3

EDIT: Also it's [options] hash [dictionary/mask]

The -o mpdec.txt at the end should be before the mask.