[VCL Cluster] problem on vcl cluster clCreateContext() -2
#1
Dear All,
I'm trying to setup a vcl cluster, everything went OK but when running vcl then I got this error:

root@hash2:/home/hash2/oclHashcat-plus-0.14# ./vclHashcat-plus64.bin -t 32 -a 7 example0.hash ?a?a?a?a example.dict
oclHashcat-plus v0.14 by atom starting...

Hashes: 6494 total, 1 unique salts, 6494 unique digests
Bitmaps: 16 bits, 65536 entries, 0x0000ffff mask, 262144 bytes
Workload: 256 loops, 80 accel
Watchdog: Temperature abort trigger disabled
Watchdog: Temperature retain trigger disabled
Device #1: Cayman, 1024MB, 0Mhz, 24MCU
Device #2: Cayman, 1024MB, 0Mhz, 24MCU
Device #3: Cayman, 1024MB, 0Mhz, 24MCU
Device #4: Cayman, 1024MB, 0Mhz, 24MCU
ERROR: clCreateContext() -2

Literally, the host can see the client now, it able to see 2x HD6990 as well but it did NOT run.

The thing different on my setup with the guide on wiki (http://www.hashcat.net/wiki/doku.php?id=...ster_howto) is I'm using Ubuntu 12.04 DESKTOP x64 version , not SERVER version. Is it the one causing problem? If not, how to solve that ERROR: clCreateContext() -2 problem?
Thanks a lot.
#2
(04-23-2013, 03:37 PM)alex Wrote: Dear All,
I'm trying to setup a vcl cluster, everything went OK but when running vcl then I got this error:

root@hash2:/home/hash2/oclHashcat-plus-0.14# ./vclHashcat-plus64.bin -t 32 -a 7 example0.hash ?a?a?a?a example.dict
oclHashcat-plus v0.14 by atom starting...

Hashes: 6494 total, 1 unique salts, 6494 unique digests
Bitmaps: 16 bits, 65536 entries, 0x0000ffff mask, 262144 bytes
Workload: 256 loops, 80 accel
Watchdog: Temperature abort trigger disabled
Watchdog: Temperature retain trigger disabled
Device #1: Cayman, 1024MB, 0Mhz, 24MCU
Device #2: Cayman, 1024MB, 0Mhz, 24MCU
Device #3: Cayman, 1024MB, 0Mhz, 24MCU
Device #4: Cayman, 1024MB, 0Mhz, 24MCU
ERROR: clCreateContext() -2

Literally, the host can see the client now, it able to see 2x HD6990 as well but it did NOT run.

The thing different on my setup with the guide on wiki (http://www.hashcat.net/wiki/doku.php?id=...ster_howto) is I'm using Ubuntu 12.04 DESKTOP x64 version , not SERVER version. Is it the one causing problem? If not, how to solve that ERROR: clCreateContext() -2 problem?
Thanks a lot.

UPDATE:
Apperantly, /etc/init.d/vcl stop on computer node , then start again, then stop and start again on host does the trick to make it working.