nVidia GEFORCE 520M driver install
i had this grafic card and i wanna use it in linux (backtrack) ..
is my card can be used in hashcat ?
i think i have CUDA GPU ...

i downloaded linux driver "NVIDIA-Linux-x86_64-310.44.run"
when i want to run it , i give a message that says Nouveau kernel is running and i must stop it ...

how can i do that ?

i add:
blacklist vga16fb
blacklist nouveau
blacklist rivafb
blacklist nvidiafb
blacklist rivatv
into /etc/modprobe.d/blacklist.conf
and add :
"# This file was installed by nvidia-current-updates
# Do not edit this file manually

blacklist nouveau
blacklist lbm-nouveau
blacklist nvidia-173
blacklist nvidia-96
blacklist nvidia-current
blacklist nvidia-173-updates
blacklist nvidia-96-updates
alias nvidia nvidia_current_updates
alias nouveau off
alias lbm-nouveau off
into /etc/modprobe.d/nvidia-graphics-drivers.conf
and add:
# generated by nvidia-installer
blacklist nouveau
options nouveau modeset=0
into /etc/modprobe.d/nvidia-installer-disable-nouveau.conf

and rebooted

but the problem still here Sad

can anyone help me to use my gpu?

tanx in advance
if you looked at your Xorg log you would see that the nouveau driver is called "nv," not "nouveau." all you need to do is stop x11 and rmmod nv.
im new in linux :-s

how can i rmmod nv ?

u mean add nv into blacklist.conf ?

in hashcat.net 's homepage i can see this message "NV users require ForceWare 310.32 or later"
what is this ?
am i should install it ?
i runned "rmmod nv" and i got something like its not exist ...
i runned "rmmod nouveau" and i unload nouveau ...
i installed that .run file complately ..
and i rebooted my system ..
when i use "startx" for see graphic interface, i give several errors and now i haven't graphic interface Sad
"rmmod nv" is the command that you run. you can blacklist it if you wish, but that won't help if it's already loaded.

the page says it requires 310.32 or later, and you have 310.44, so you're fine.
i think i unloaded the nv ...
because i installed "NVIDIA-Linux-x86_64-310.44.run" complately ...

but now , i have not gui interface after run startx


i dont know , what should i do now ...!?
im in my windows7 now ..
i'll boot into my linux and run hashcat from terminal to check can i use cuda or not ...

tanx in advance

this is my X Server's log ..

i cant use X gui Sad

can any one help me ?

huh , after several tries , i runed /usr/bin/kbd and reconfigured the xorg config file i think ..
and runed the gui again ...

but when i run oclhashcat it with says
FATA: nvidia_current_update module not found

and now ???

how can i use this pussy? Sad
I would suggest you upgrade to the newest release of your distro, i.e. The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali) linux.

After that download the nvidia drivers from the NV site. You then need to remove all the non-proprietary NV stuff (i.e. distro-provided drivers) e.g. by searching them via:
$  sudo dpkg --get-selections|grep -i nvidia
$  sudo dpkg --get-selections|grep -i nouveau

maybe you need also this one:
$  sudo dpkg --get-selections|grep -i nv

Carefully remove (sudo apt-get remove [package]) ALL the nvidia non-proprietary (and previous installed) NV stuff, reboot, switch to a different shell (e.g. CTRL-ALT-F1), login, stop the display manager (i.e. /etc/init.d/gdm stop sudo service gdm stop) and run the installer (.run file) as root.

You should also try to google for tutorials for your specific distro and card vendor combination (ie. The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali)/nvidia), e.g. @eljolot did exactly that and he found a solution for (The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali)/amd) and wrote a howto here: https://hashcat.net/forum/thread-2222-po...l#pid13413 . (This is 4 sure not totally suitable for NV, but maybe both have some basic steps in common, i.e. removing packages/rebooting/reinstalling etc)

Try to find some howto's on internet first; if still not working, consider also getting (faster) help on hashcat's IRC channel: http://webchat.freenode.net/?channels=hashcat

Good luck
before anyyyyything , i must say TANKYOU VERY MUCH to philsmd for his biiiiiiiiiig help to me in hashcat's IRC...

he spend many time for me <3
tanx dude <3

after this i wanna run hashcat for my two md5(unix) hashs
i saved these hashes in a text

i wanna check all combnations from a-z & A-Z & 0-9
can anyone please write the exact switches of hashcat for me ?
i just know , i must set -m 500 ... whatabout -a or others ...?

tanQ so much <3
its the result of our work Tongue Tongue <3
Glad to help.
But let me say one thing: I don't like your follow-up post at all.
I would like to see a howto tutorial how we resolved the problem instead.

You should have posted here the solution for the threads problem and post your next question in another thread (or better use the forum search and you find *several* topics about the *very* same questions).

So the solution for the problem was basically:
1. Try to remove everything installed before (nouveau and nvidia stuff)... via apt-get remove, most of all stuff like xserver-xorg-video-nouveau etc
2. edit grub.cfg and add as boot option (to the correct kernel entry) after splash or others: nouveau.modeset=0
3. reboot, stop the kdm/gdm service (or just do not run startx)
4. (re-)install the drivers w/ the .run file and we tried to use also the -Z option, i.e. blacklist nouveau (may or may not be necessary)...
5. try to reboot. It should work now...
6. we had another problem since @sangiiin had 2 cards on his notebook (intel + NV), we had to use some nvidia-xconfig, e.g. nvidia-xconfig --busid=`nvidia-xconfig --query-gpu-info|grep BusID|sed 's/PCI BusID : PCI:/PCI:/'` (also check this: http://superuser.com/questions/251693/ho...not-nvidia)
7. now the nvidia modules should load on reboot and startx shouldn't report any problem (hopefully), maybe some manual xorg.conf modifications may be necessary too

@sangiiin: don't use this thread for totally different questions, nobody would be able to find the questions/solutions for the second questions... use forum search/wiki instead