can't make cmd
using ubuntu, can't create command for bruting.

Im tried:

./hashcat-cli64.bin -m 400 -a 0 -ot.txt -p : --username hashes.txt

Get nothing:

Usage: hashcat [options] hashfile [mask|wordfiles|directories]

Try --help for more help.

What I missed?

hashes.txt contains hashes by format username:hashConfusedalt
-a 0 is not for "bruting", nor for mask attack (

to use a mask attack and/or brute force a hash you need to use
-a 3

from --help:

* Attack modes:
0 = Straight
3 = Brute-force

Also you need to specify a mask, so a valid command would be something like this:
./hashcat-cli64.bin -m 400 --username -o t.txt -a 3 --pw-min 7 --pw-max 7 hashes.txt ?a?a?a?a?a?a?a
Hm. I dont see any references to a mask (?a?a?a) in help. I mean how it must be described
But it is clearly there:

* Built-in charsets:

?l = abcdefghijklmnopqrstuvwxyz
?d = 0123456789
?s = !"#$%&'()*+,-./:;<=>?@[\]^_`{|}~
?a = ?l?u?d?s

?a = ?l?u?d?s (lower case, upper case letters, digits and special characters)
line lenght exceptions errors....
look here:

the signature is either:
wiki says for each symbol I need to put one placeholder. am I right? but there is placeholders only for upper case or lower case, so how to make both of them?

and I really dont get what connection between line exception lenght and type of hash
read here:

you need to define a custom charset like this:
-1 ?u?l ?1?1?1?1?1?1?1

./hashcat-cli64.bin -m 400 --username -o t.txt -a 3 -1 ?u?l --pw-min 7 --pw-max 7 hashes.txt ?1?1?1?1?1?1?1

All details can be found on the wiki, especially
I get same error if I wanted to combinator attack. custom charset for what? This is for password, not for hash - am I right?