hashcat and linux
#1
Hi
I am new with hashcat.
I tested hashcat with mask on windows 8.1 and on The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali) linux(virtual mashine)
both 64 bit

I started same command in both machines and I was wondering why windows with 8 cores takes longer
than virtual machine with 3.

little comparison and I noticed that in linux it only uses 6 character mask.

command I started in both is same(below)
hashcat -m 0 -a 3 md5_hash.txt ?a?a?a?a?a?a?a?a

mask is 8 characters long, but linux side it uses only 6, is there bug in linux version or am I missing something?

file contains 3 simple passwords that are hashed with md5
Reply
#2
hashcat command line version applies masks of incremental lengths, i.e. first try ?a than ?a?a, etc. Seems like ?a?a?a?a?a?a [6] is taking a long time (no surprise there) so add "--pw-min=8" to jump straight to 8 character. There's also a --pw-max option if you want to use that.

So try:
hashcat -m 0 -a 3 --pw-min=8 md5_hash.txt ?a?a?a?a?a?a?a?a
Reply
#3
thanks I will try that and
I had that min-pw parameter earlier.
I understood that min-pw=6 will skip passwords less than 6 character long passwords.

But
I executed hashcat in both from command line.

linux versio says "input mode: mask (?a?a?a?a?a?a) [6]"
even in command line I have 8x ?a
also estimation time was something like 15-18 hours

on windows
same command says "input mode: mask (?a?a?a?a?a?a?a?a) [8]"
estimation time is 194 days 2 hours ....

only difference is that linux is running in virtual machine.
I will try same command at home where I have linux installed straight in computer
Reply
#4
(08-21-2015, 11:57 AM)kirini Wrote: I had that min-pw parameter earlier.

Well it wasn't there in the command you posted. You should really copy-paste the EXACT command you're using otherwise you will just waste people's time. I'm still not convinced your command is correct...
Reply
#5
Just make sure you have put --pw-min=8 in the command line of both computers. I bet you forgot to add it to the one displaying 6 x ?a.
Reply
#6
no I did not forgot.
What I ment with "i use to have" I mean that I first excecuted that command including min-pw=6
I stopped that and then I started same command without min-pw parameter.



anyway just made new test.
it seems that input mode shows how long password it is testing.
so when it say [6] it is only going thru 6 char long password.

5 character long goes thru in <10min so I probably missed that earlier.

but now I wonder why in windows side it goes straight to 8 char long passwords, it skips 1-7 character long passwords.

I probably have to do some testing and take screenshots.
Reply
#7
It is also important that you let us know about the exact version(s) of cpu hashcat. And try with the newest version (download, extract and run it).

The reason for this is: cpu hashcat previous to 0.50 did increment (-i or --increment) by default. So you might just didn't see that it started with length 1, then 2, then 3 ... (very quickly) and finally did take some more time on 6 char long passwords.

Newest cpu hashcat version have --increment, --increment-min and --increment-max similar to oclHashcat (and they do not increment the mask by default, but start at *exactly* the length of the mask if no -i or --increment was specified).

@mastercracker: --pw-min parameter does not exist anymore, it was replaced (as mentioned above, in the changes.txt file and release notes with --increment-min)
Reply