OSX 10.10 (-m 7100) Hash Question
Hey all, I'm working on a pentest engagement and got the hash for an OSX (v10.10.5) account usingĀ this technique.

According to the plist file, it's a SALTED-SHA512-PBKDF2 key, I have the entropy, iterations, and salt values properly created in a file on disk.

When I run oclHashcat (1.37) against it, I get a line-length exception.
When I run hashcat (0.50) against it, it recognizes the hash and works perfectly.

I get the exact same errors when I use the Mode 7100 example hash from here.
Can anyone tell me what might be causing the inconsistencies? I'd certainly prefer to use oclHashcat against it to better leverage my GPUs.

you need to remove the whitespaces (most importantly the spaces " ") at the end of the lines.
There are no whitespaces at the end of the lines. Thank you for the suggestion, though.

The line is $ml$iterations$salt$entropy with no whitespace anywhere.
Make sure you point oclhashcat to the right hash file. Otherwise can you post the 2 command lines you used for hashcat and oclhashcat?
Here they are:

~/hashcat-0.50$ ./hashcat-cli64.bin -m 7100 ~/hashes/customers/X/hash.txt ~/dictionaries/g0tmi1k-18-in-1.txt

Which gives me:

This copy of hashcat will expire on 01.01.2016. Please upgrade to continue using hashcat.

Initializing hashcat v0.50 with 24 threads and 32mb segment-size...

Added hashes from file /home/opencl/hashes/customers/X/hash.txt: 1 (1 salts)
Activating quick-digest mode for single-hash with salt

[s]tatus [p]ause [r]esume [b]ypass [q]uit => s

Input.Mode: Dict (/home/opencl/dictionaries/g0tmi1k-18-in-1.txt)
Index.....: 1/1166 (segment), 2971922 (words), 33550336 (bytes)
Recovered.: 0/1 hashes, 0/1 salts
Speed/sec.: 200 plains, 200 words
Progress..: 1368/2971922 (0.05%)
Running...: 00:00:00:07
Estimated.: 00:04:07:32

And oclHashcat:

~/oclHashcat-1.37$ ./oclHashcat64.bin -m 7100 ~/hashes/customers/X/hash.txt ~/dictionaries/g0tmi1k-18-in-1.txt

And running the second gives me:

oclHashcat v1.37 starting...

WARNING: Hashfile '/home/opencl/hashes/customers/X/hash.txt' in line 1 ($ml$11111$xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx$xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx): Line-length exception
Parsed Hashes: 1/1 (100.00%)

ERROR: No hashes loaded
oclHashcat has tougher hash verification checks. Make sure your hash matches the one from the example hash page.
I'd goofed with the example hash (left a whitespace, now it works). Mine still doesn't. I'll admit I don't know enough about the hashing algorithms to say if this makes a difference or not, but:

Example Hash:
* Iterations: 35460
* Salt Length: 64
* Entropy Length: 128 characters

My Hash:
* Iterations: 42735
* Salt Length: 92
* Entropy Length: 346

Would that be what could cause the line length exception?
I'd guess invalid extraction of the hash. The Iteration count sounds good