ERROR: clCreateContext() : -2 : CL_UNKNOWN_ERROR

I installed latest Intel OpenCL runtime v16.1 on my Win 10 x64 - Core 2 Duo T7600 (Merom) and tried to use hashcat v3.00 but I got the following error:

ERROR: clCreateContext() : -2 : CL_UNKNOWN_ERROR

It is recognized as:

OpenCL Platform #1: Intel(R) Corporation
- Device #1: Intel(R) Core(TM)2 CPU         T7600  @ 2.33GHz, 765/3062 MB allocatable, 2MCU

Is Core 2 Duo compatible with hashcat v3.00 CPU ?

My Core 2 Duo supports up to SSSE3 (no SSE4.x) SIMD architecture - 1st generation Core 2 Duo.



It seems that my Core 2 Duo E7300 with SSE4.1 support, suffers from the same problem, same error.

My Sandybridge Core i5-2400 works fine, so it's either a bug of hashcat or a requirement for SSE4.2 (?)
I found out myself what is the problem.

As I assumed above, unfortunately, all latest Intel OpenCL runtimes from 14.2 and above require a Core processor or higher, meaning SSE4.2 or higher.

In order to use Intel OpenCL on SSE4.1 (Core 2 Duo) you have to use OpenCL 2012 (!) runtime.

For 1st generation Core 2 Duo (SSSE3) you have to go even on older versions.

One other solution could be AMD APP SDK which supports even SSE2 processor, but hashcat complains that it is not native for Intel processors.

I'll try both solutions on my older SSSE3 Core 2 Duo to test them.
That's good info, thanks for letting us know
OK, from my little research it seems that Core 2 Duo 1st generation (Conroe/ Merom) and older P4 have no luck of using native Intel's OpenCL runtime libraries.

It seems that even from the first implementation of Intel's OpenCL CPU runtime the requirements were minimum SSE4.1 support.

On the other hand AMD supports even SSE2, so I installed latest AMD APP SDK v3.0 on my Core 2 Duo T7600.

The exact version is OpenCL 1.2 AMD-APP 1800.8 (sse2)

The AMD OpenCL runtime doesn't recognize SSE3/SSSE3 of Core 2 Duo.

The benchmark results of some popular algorithms are disappointing though, but of course it works using --force switch

Hashtype: MD4

Speed.Dev.#1.: 61809.6 kH/s (109.87ms)

Hashtype: NTLM

Speed.Dev.#1.: 63067.8 kH/s (112.07ms)

Hashtype: LM

Speed.Dev.#1.: 10681.5 kH/s (97.68ms)

Hashtype: MD5

Speed.Dev.#1.: 47481.2 kH/s (98.56ms)

Hashtype: WPA/WPA2

Speed.Dev.#1.:     1209 H/s (101.04ms)

Hashtype: 7-Zip

Speed.Dev.#1.:       13 H/s (108.60ms)

Hashtype: Office 2013

Speed.Dev.#1.:       21 H/s (109.31ms)

Hashtype: Office 2010

Speed.Dev.#1.:       61 H/s (122.15ms)

Hashtype: CRC32

Speed.Dev.#1.: 79577.9 kH/s (108.16ms)

Hashtype: RAR3-hp

Speed.Dev.#1.:       89 H/s (67.43ms)

Hashtype: RAR5

Speed.Dev.#1.:       41 H/s (108.56ms)

I have a SSE4.1 Core 2 Duo that I could try AMD APP on it, but I would like to also test Intel's OpenCL runtime.

If someone has a link to download Intel OpenCL 2012 SDK or previous, I could give it a try.

I couldn't find those installers, Intel doesn't offer such old versions.