Am I doing something wrong?
#1
I just downloaded the latest version to try it out.

This is running on Win7 64-bit, the machine has a Core i7 8-core CPU and an nVidia GeForce GT 525 M. It worked fine with the older version, cudahashcat.

I started a command prompt with Administrator privileges, changed to the hashcat directory, then used the following:
hashcat64.exe -m 0 -a 3 --increment-min=1 --increment-max=16 -1 .0123456789 -i 01e8231d1c6f91ff34ce69dfbb41ae84 ?1?1?1?1?1?1?1?1?1?1?1?1?1?1?1?1

The MD5 hash corresponds to 1.0.0.0, which I was using as a test.

Hashcat64 returns the following (extraneous blank lines removed to save space):
Quote:hashcat (v3.00-1-g67a8d97) starting...

OpenCL Platform #1: NVIDIA Corporation
======================================
- Device #1: GeForce GT 525M, 512/2048 MB allocatable, 2MCU
- Device #1: WARNING! Kernel exec timeout is not disabled, it might cause you errors of code 702
             See the wiki on how to disable it: https://hashcat.net/wiki/doku.php?id=timeout_patch

WARNING: NVML library load failed, proceed without NVML HWMon enabled.
Hashes: 1 hashes; 1 unique digests, 1 unique salts
Bitmaps: 16 bits, 65536 entries, 0x0000ffff mask, 262144 bytes, 5/13 rotates
Applicable Optimizers:
* Zero-Byte
* Precompute-Init
* Precompute-Merkle-Demgard
* Meet-In-The-Middle
* Early-Skip
* Not-Salted
* Not-Iterated
* Single-Hash
* Single-Salt
* Brute-Force
* Raw-Hash
Watchdog: Temperature abort trigger disabled
Watchdog: Temperature retain trigger disabled

- Device #1: Kernel m00000_a3.1845c46e.kernel not found in cache! Building may take a while...

=== Build failed, retry with optimization disabled ===

ERROR: clBuildProgram() : -11 : CL_BUILD_PROGRAM_FAILURE

=== Build Options : -I "C:/Users/xxxxxxx/Desktop/hashcat3/OpenCL/" -D VENDOR_ID=32 -D CUDA_ARCH=201 -D VECT_SIZE=2 -D DEVICE_TYPE=4 -D
 DGST_R0=0 -D DGST_R1=3 -D DGST_R2=2 -D DGST_R3=1 -D DGST_ELEM=4 -D KERN_TYPE=0 -D _unroll -cl-std=CL1.1 ===

=== Build Log (start) ===
:10:10: fatal error: 'inc_vendor.cl' file not found
#include "inc_vendor.cl"
         ^

=== Build Log (end) ===
- Device #1: Kernel C:\Users\xxxxxxx\Desktop\hashcat3/OpenCL/m00000_a3.cl build failure. Proceeding without this device.

It then flips through the output quickly and ends without solving the hash:
Quote:Session.Name...: hashcat
Status.........: Exhausted
Input.Mode.....: Mask (?1) [1]
Hash.Target....: 01e8231d1c6f91ff34ce69dfbb41ae84
Hash.Type......: MD5
Time.Started...: 0 secs
Recovered......: 0/1 (0.00%) Digests, 0/1 (0.00%) Salts
Progress.......: 0/11 (0.00%)
Rejected.......: 0/0 (0.00%)
Restore.Point..: 18446744073709551615/1 (1844674407370955161600.00%)

It does this all the way up to:
Quote:Session.Name...: hashcat
Status.........: Exhausted
Input.Mode.....: Mask (?1?1?1?1?1?1?1?1?1?1?1?1?1?1?1?1) [16]
Hash.Target....: 01e8231d1c6f91ff34ce69dfbb41ae84
Hash.Type......: MD5
Time.Started...: 0 secs
Recovered......: 0/1 (0.00%) Digests, 0/1 (0.00%) Salts
Progress.......: 0/45949729863572161 (0.00%)
Rejected.......: 0/0 (0.00%)
Restore.Point..: 18446744073709551615/34522712143931 (53433644.00%)

Then prints:
Quote:Started: Mon Jul 25 18:40:33 2016
Stopped: Mon Jul 25 18:40:37 2016

Am I doing something wrong?
Reply
#2
Quote:- Device #1: WARNING! Kernel exec timeout is not disabled, it might cause you errors of code 702
            See the wiki on how to disable it: https://hashcat.net/wiki/doku.php?id=timeout_patch

I've made the necessary registry change to get rid of this warning. No change from above.
Reply
#3
Please use the beta from here: https://hashcat.net/beta
Reply