Ubuntu 16.04 LTS NVIDIA Setup Guide
#11
I found the directions about building a hash cracking rig from

http://www.netmux.com/blog/how-to-build-...acking-rig  to be excellent.

Although it uses  four  GTX 1070 FEs  in the text, I sub'ed four 1080 FEs without any problems.

However, the blog post specifies older software:

-Ubuntu 14.0.4.5 Desktop amd64
-Intel OpenCL Runtime 16.1 x64 Ubuntu Driver
-Nvidia Linux x86_64 375.20 Driver
-Hashcat v3.20

So these directions may not be applicable for everyone.

What may be of interest are several "gotcha" notes under the "INSTALLING SOFTWARE" section.

Check the "Step by Step" install procedures and compare with the latest software.
Reply
#12
Hi,

just added a new GTX 1080 to my current rig.
I'm running Ubuntu 16.04 Server and I was able to control my 2 GPUs with this guide and nvidia-settings commands.

Here's my nvidia-smi:
Code:
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 384.98                 Driver Version: 384.98                    |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  GeForce GTX 1080    Off  | 00000000:01:00.0 Off |                  N/A |
| 27%   29C    P8     5W / 180W |     11MiB /  8112MiB |      0%      Default |
+-------------------------------+----------------------+----------------------+
|   1  GeForce GTX 1080    Off  | 00000000:02:00.0 Off |                  N/A |
|  0%   58C    P0    39W / 210W |      1MiB /  8114MiB |      0%      Default |
+-------------------------------+----------------------+----------------------+
|   2  GeForce GTX 1080    Off  | 00000000:05:00.0  On |                  N/A |
|  0%   54C    P0    41W / 240W |     10MiB /  8114MiB |      0%      Default |
+-------------------------------+----------------------+----------------------+

+-----------------------------------------------------------------------------+
| Processes:                                                       GPU Memory |
|  GPU       PID   Type   Process name                             Usage      |
|=============================================================================|
|    0      1565      G   /usr/lib/xorg/Xorg                             8MiB |
|    2      1565      G   /usr/lib/xorg/Xorg                             7MiB |
+-----------------------------------------------------------------------------+

It looks like my GPU 1 (new one) is not fully "working".
Hashcat can control its fan, but when I do:
Code:
nvidia-settings -a [gpu:1]/GPUFanControlState=1 -a [fan-1]/GPUTargetFanSpeed=100

my nvidia-smi:
Code:
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 384.98                 Driver Version: 384.98                    |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  GeForce GTX 1080    Off  | 00000000:01:00.0 Off |                  N/A |
| 27%   29C    P8     6W / 180W |     11MiB /  8112MiB |      0%      Default |
+-------------------------------+----------------------+----------------------+
|   1  GeForce GTX 1080    Off  | 00000000:02:00.0 Off |                  N/A |
|  0%   57C    P0    39W / 210W |      1MiB /  8114MiB |      0%      Default |
+-------------------------------+----------------------+----------------------+
|   2  GeForce GTX 1080    Off  | 00000000:05:00.0  On |                  N/A |
|100%   31C    P0    44W / 240W |     10MiB /  8114MiB |      0%      Default |
+-------------------------------+----------------------+----------------------+

+-----------------------------------------------------------------------------+
| Processes:                                                       GPU Memory |
|  GPU       PID   Type   Process name                             Usage      |
|=============================================================================|
|    0      1565      G   /usr/lib/xorg/Xorg                             8MiB |
|    2      1565      G   /usr/lib/xorg/Xorg                             7MiB |
+-----------------------------------------------------------------------------+
and when I do:
Code:
nvidia-settings -a [gpu:2]/GPUFanControlState=1 -a [fan-2]/GPUTargetFanSpeed=100
I recive this message:
Code:
ERROR: Error assigning value 100 to attribute 'GPUTargetFanSpeed' (horse-power:0[fan:2]) as

      specified in assignment '[fan-2]/GPUTargetFanSpeed=100' (Unknown Error).


It looks like GPU number it's not assigned correctly.. any ideas ?

Thanks in advance
Reply
#13
shouldn't you use [fan:1] and [fan:2] instead ?
Reply
#14
Same resault

Code:
nvidia-settings -a [gpu:2]/GPUFanControlState=1 -a [fan:2]/GPUTargetFanSpeed=30



ERROR: Error assigning value 30 to attribute 'GPUTargetFanSpeed' (horse-power:0[fan:2]) as
       specified in assignment '[fan:2]/GPUTargetFanSpeed=30' (Unknown Error).

New info (don't know if usefull):
Code:
nvidia-xconfig --query-gpu-info
Number of GPUs: 3

GPU #0:
  Name      : GeForce GTX 1080
  UUID      : GPU-d2e19eee-589a-b609-5daf-f21754c2829b
  PCI BusID : PCI:1:0:0

  Number of Display Devices: 0


GPU #1:
  Name      : GeForce GTX 1080
  UUID      : GPU-bb9f11c3-be17-d645-e76e-4c4cdf451842
  PCI BusID : PCI:2:0:0

  Number of Display Devices: 0


GPU #2:
  Name      : GeForce GTX 1080
  UUID      : GPU-d0cd4902-e657-cdeb-7d6b-eeb5e273b81e
  PCI BusID : PCI:5:0:0

  Number of Display Devices: 0

nvidia-smi -q -d PERFORMANCE

==============NVSMI LOG==============

Timestamp                           : Wed Nov  8 11:13:08 2017
Driver Version                      : 384.98

Attached GPUs                       : 3
GPU 00000000:01:00.0
    Performance State               : P8
    Clocks Throttle Reasons
        Idle                        : Active
        Applications Clocks Setting : Not Active
        SW Power Cap                : Not Active
        HW Slowdown                 : Not Active
        Sync Boost                  : Not Active
        SW Thermal Slowdown         : Not Active

GPU 00000000:02:00.0
    Performance State               : P0
    Clocks Throttle Reasons
        Idle                        : Active
        Applications Clocks Setting : Not Active
        SW Power Cap                : Not Active
        HW Slowdown                 : Not Active
        Sync Boost                  : Not Active
        SW Thermal Slowdown         : Not Active

GPU 00000000:05:00.0
    Performance State               : P0
    Clocks Throttle Reasons
        Idle                        : Active
        Applications Clocks Setting : Not Active
        SW Power Cap                : Not Active
        HW Slowdown                 : Not Active
        Sync Boost                  : Not Active
        SW Thermal Slowdown         : Not Active

Another thing, I'm using a USB raiser for GPU #1 and #2. The recently added is from a PCIe 8x (regular GPU slot) the other is from a PCIe 2x (smaller slots).
Reply
#15
how did you set up the system? x11 and nvidia-xconfig . Did you set cool-bits etc ?

maybe this is relevant: https://hashcat.net/forum/thread-6036-po...l#pid32262
(even if probably not up to date, but you could test)

My guess is that your 2nd card was not configured correctly with nvidia-xconfig and therefore it doesn't work anymore (or not at all for the second card)
Reply
#16
I followed this guid, the only exception was that since I had the drivers already installed and working I just missed the step for the instalation, all the other steps I did again.
So:
--cool-bits=12
xdm
I had this done previously:
Code:
cat > /etc/X11/xdm/Xsetup << EOF
export PATH=/bin:/usr/bin:/sbin
export HOME=/root
export DISPLAY=:0
xset -dpms
xset s off
xhost +
EOF
and I also did this:
Code:
sed -i '/Driver/a \ \ \ \ Option         "Interactive" "False"' /etc/X11/xorg.conf
Reply
#17
New information:
Code:
XNVCTRLQueryTargetAttribute() failed.

This error typically occurs when you did not set up NVidia Coolbits.
To fix, run this command:
    sudo nvidia-xconfig --cool-bits=12
Do not forget to restart X afterwards.

When running hashcat I have this error, but it seems to work normally.. in my xorg I have all devices and screens with "correct" config I think.
I used the above commands to create it
Reply
#18
maybe it's just a problem of communication, but you must make sure that you use all the steps
nvidia-xconfig
sed
nvidia-settings
(and eventually also nvidia-smi to set the power limit)

also see:
https://hashcat.net/forum/thread-4569-po...l#pid25931
https://hashcat.net/forum/thread-5498-po...l#pid29740
(both of these links might already be very old and the settings have changed slightly, but the general idea is still the same)
Reply
#19
Very strange, I can set some values, but not the funspeed...
Code:
nvidia-settings -a [gpu:0]/GPUPowerMizerMode=1 \
> -a [gpu:1]/GPUPowerMizerMode=1 \
> -a [gpu:2]/GPUPowerMizerMode=1 \
> -a [gpu:0]/GPUGraphicsClockOffset[3]=100 \
> -a [gpu:1]/GPUGraphicsClockOffset[3]=100 \
> -a [gpu:2]/GPUGraphicsClockOffset[3]=100 \
> -a [gpu:0]/GPULogoBrightness=0 \
> -a [gpu:1]/GPULogoBrightness=0 \
> -a [gpu:2]/GPULogoBrightness=0 \
> -a [gpu:0]/GPUFanControlState=1 \
> -a [gpu:1]/GPUFanControlState=1 \
> -a [gpu:2]/GPUFanControlState=1 \
> -a [fan:0]/GPUTargetFanSpeed=100 \
> -a [fan:1]/GPUTargetFanSpeed=100 \
> -a [fan:2]/GPUTargetFanSpeed=100

  Attribute 'GPUPowerMizerMode' (horse-power:0[gpu:0]) assigned value 1.

  Attribute 'GPUPowerMizerMode' (horse-power:0[gpu:1]) assigned value 1.

  Attribute 'GPUPowerMizerMode' (horse-power:0[gpu:2]) assigned value 1.


  Attribute 'GPUGraphicsClockOffset' (horse-power:0[gpu:1]) assigned value 100.


  Attribute 'GPULogoBrightness' (horse-power:0[gpu:0]) assigned value 0.

  Attribute 'GPULogoBrightness' (horse-power:0[gpu:1]) assigned value 0.

  Attribute 'GPULogoBrightness' (horse-power:0[gpu:2]) assigned value 0.

  Attribute 'GPUFanControlState' (horse-power:0[gpu:0]) assigned value 1.

  Attribute 'GPUFanControlState' (horse-power:0[gpu:1]) assigned value 1.


  Attribute 'GPUTargetFanSpeed' (horse-power:0[fan:0]) assigned value 100.

  Attribute 'GPUTargetFanSpeed' (horse-power:0[fan:1]) assigned value 100.


ERROR: Error assigning value 100 to attribute 'GPUTargetFanSpeed' (horse-power:0[fan:2]) as
       specified in assignment '[fan:2]/GPUTargetFanSpeed=100' (Unknown Error).
Reply
#20
(11-09-2017, 03:55 PM)jimbas Wrote: Very strange, I can set some values, but not the funspeed...

NV often changes the attribute names (when driver version updates).
Reply