Old hardware: how to run outdated oclhashcat
#1
I have a Windows 10 system with 2 AMD GPU's: HD 5450 and HD 7700. The latest AMD driver that will support them is 15.11. The current versions of hashcat are documented to require AMD 15.12 or later. I've tried both 3.00 and 3.20 and they both fail with a "hashcat64.exe has stopped working" popup error message.

Roughly a year ago I was able to successfully use oclhashcat64.exe with this hardware, but I now get the message "ERROR: This copy of oclHashcat is outdated. Get a more recent version."

Is there a way to bypass the error and continue to use the old oclhashcat that does work with my hardware? or is there a way to use the newer versions with this hardware?
Reply
#2
(12-31-2016, 12:33 AM)holistone Wrote: I have a Windows 10 system with 2 AMD GPU's: HD 5450 and HD 7700. The latest AMD driver that will support them is 15.11. The current versions of hashcat are documented to require AMD 15.12 or later. I've tried both 3.00 and 3.20 and they both fail with a "hashcat64.exe has stopped working" popup error message.

Roughly a year ago I was able to successfully use oclhashcat64.exe with this hardware, but I now get the message "ERROR: This copy of oclHashcat is outdated. Get a more recent version."

Is there a way to bypass the error and continue to use the old oclhashcat that does work with my hardware? or is there a way to use the newer versions with this hardware?

2.0 and up can be found on github.

https://github.com/hashcat/hashcat/releases

Legacy stuff can be found here:

https://hashcat.net/files_legacy/hashcat-0.42.7z
https://hashcat.net/files_legacy/hashcat-0.48.7z
https://hashcat.net/files_legacy/hashcat-0.49.7z

https://hashcat.net/files_legacy/cudaHashcat-1.20.7z
https://hashcat.net/files_legacy/cudaHashcat-1.21.7z
https://hashcat.net/files_legacy/cudaHashcat-1.30.7z
https://hashcat.net/files_legacy/cudaHashcat-1.31.7z
https://hashcat.net/files_legacy/cudaHashcat-1.32.7z
https://hashcat.net/files_legacy/cudaHashcat-1.37.7z
https://hashcat.net/files_legacy/cudaHashcat-2.00.7z
https://hashcat.net/files_legacy/cudaHashcat-2.01.7z

https://hashcat.net/files_legacy/oclHashcat-1.20.7z
https://hashcat.net/files_legacy/oclHashcat-1.21.7z
https://hashcat.net/files_legacy/oclHashcat-1.31.7z
https://hashcat.net/files_legacy/oclHashcat-1.33.7z
https://hashcat.net/files_legacy/oclHashcat-1.34.7z
https://hashcat.net/files_legacy/oclHashcat-1.35.7z
https://hashcat.net/files_legacy/oclHashcat-1.36.7z
https://hashcat.net/files_legacy/oclHashcat-1.37.7z
https://hashcat.net/files_legacy/oclHashcat-2.00.7z
https://hashcat.net/files_legacy/oclHashcat-2.01.7z

https://hashcat.net/files_legacy/oclHash...us-0.13.7z
https://hashcat.net/files_legacy/oclHash...us-0.14.7z

You will have to turn your system date back for it to work.
Reply
#3
(12-31-2016, 01:50 AM)duhblow7 Wrote: You will have to turn your system date back for it to work.

I can understand the necessity of new versions not supporting old hardware, but I fail to see the justification for setting a fixed expiration date on any version. Why not allow users with older hardware to run previous versions? A legacy flag (for example -legacy) would simply bypass the expiration date.

Is the source code for the earlier versions available?
Reply
#4
No, hashcat went OSS with v2.00.
Reply
#5
(12-31-2016, 01:50 AM)duhblow7 Wrote: You will have to turn your system date back for it to work.

When i turn back the system date I still get a "oclHashcat64.exe has stopped" working popup window. I suspect I need backdated AMD openCL drivers as well. Is there documentation for which AMD versions are needed with specific legacy oclhashcat versions? I was using version 1.36 but I could also use 2.01.
Reply
#6
The ideal versions are usually in docs/readme.txt somewhere in the header
Reply
#7
The older versions can be made to work regardless of date by binary patching , of course with the kind permission of atom, but you may still get the not working msg on windows 10, as it has nothing to do with the date or driver but with the OS, but I can confirm this is working on win7. Win 10 gives me the same error.
Reply
#8
Is there a way to run it on old The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali) 1.06 ?
Reply