No devices found/left error - The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali) 2017?
I've only had The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali) installed for a couple of weeks now and I'm still getting familiar with the tools.  At first it was mostly Wireshark, Ettercap, and Aircrack-ng.  But, I've just recently read some about rule based dictionaries, and also wanted to try some of those against several handshakes that I have.  So, about an hour ago I tried out Hashcat for the first time, but got an error before I got anything up and running with it.  I've only found several articles relating to my particular situation, but I'm not quite sure if they nail it exactly, or if they're just really close to what I'm experiencing.  The error that they talk about seems to be the same, but I have'nt seen one of them mention my exact error output or anything like that.  So, I figured that I'd ask the experts.

    Basically, I tried running it and it gave some error output on the first command that I tried executing.  There's a screenshot attached.  I'm thinking that I probably need to install an AMD driver for OpenCL, but I'm not really sure.  And, since that whole process will be new to me as well, I figured that I might as well be on the right track before I start out doing it.

    What do you suppose my next step(s) should be, based on the output of the attached screenshot?

Attached Files
.png   nodevicesfound_left.png (Size: 204.97 KB / Downloads: 7)
My suggestion would be to:
- do not use The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali), use another Linux distribution (Ubuntu for instance is officially supported by most of the driver vendors)
- do not use aircrack/aircrack-ng to capture wlan data, use hcxtools ( instead

The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali) is known to have messed up everything it could possible mess up by creating hashcat related packages with dependencies that do not make the slightest sense (like pocl and mesa dependencies).

Of course, even if you switch to ubuntu, you need to install the correct driver for your GPUs/CPUs (the recommended versions are mentioned on the front page
Thanks, philsmd. That hcxtools...  I'll probably try that one and see if it fixes the error (after I install the correct driver(s) that I need).  I was using Aircrack-ng (w/ Wireshark in the background) to capture wlan data, but then I still have to convert those *.cap files to *.hccapx files.  That hcxtools might enable Hashcat to read the captures better.

    ... Looking at my driver options, after I get the OpenCL runtime for the Intel CPU that I've got, do you suppose that I ought to go with the "AMDGPU-Pro Driver" (16.40 or later), since I'll be booted to The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali) when I use Hashcat (and the The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali) OS is where Hashcat is installed)?  This setup is such that it was originally a Win7 machine, that was upgraded to Win10.  I was going to set it up to dual boot between Win10/The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali), but the HDD's MBR partitioning scheme is already full with the max number of 4 primary partitions (whosever bright idea that was at the factory).  So, I've got a ton of space left on the HDD for a The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali) intall, but I'm hesitant to convert the partitioning scheme to GPT instead of MBR yet (supposedly it can be done with no data loss, but I'm not holding my breath just yet).  So, in the meantime, I'm booting to The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali) 2017.1 rolling release on a live USB drive.

    ... As far as trying to get the correct driver that I need, which one do you suppose I should try first?  I'm not versed in Linux enough to feel confident about finding out that info yet (I don't think), but just nosing around some, I can see:

1) When I do:  lspci -vnn | grep VGA -A 12 + [enter]  ... I see the following output:

00:02.0 VGA compatible controller [0300]: Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 02) (prog-if 00 [VGA controller])
    Subsystem: Hewlett-Packard Company Core Processor Integrated Graphics Controller [103c:163d]
    Flags: bus master, fast devsel, latency 0, IRQ 28
    Memory at c0000000 (64-bit, non-prefetchable) [size=4M]
    Memory at b0000000 (64-bit, prefetchable) [size=256M]
    I/O ports at 5050 [size=8]
    [virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
    Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
    Capabilities: [d0] Power Management version 2
    Capabilities: [a4] PCI Advanced Features
    Kernel driver in use: i915
    Kernel modules: i915

01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Robson CE [Radeon HD 6370M/7370M] [1002:68e4] (rev ff) (prog-if ff)
    !!! Unknown header type 7f
    Kernel driver in use: radeon
    Kernel modules: radeon

    ... That output displays more specific info for the Intel integrated graphics controller, but the bottom section does show "... [AMD/ATI] Robson CE [Radeon HD 6370M/7370M]".  Only based on the above output, I would guess that I have an Intel grahics card, but I just glanced down a few minutes ago and noticed a sticker on this machine's case that said "ATI Mobility Radeon switchblade graphics".  That kind of sways me to think that it's an AMD graphics card.  I would just take the side off and look if it were a desktop unit, but it's a hassle to get into and last time, I broke one clip (meaningless, but still).  I would normally snoop around and see what the hardware manager or device manager had to say (Windows), but I don't know my way around Linux that good yet.  I guess maybe, I should try out the AMD driver first and then give the Intel one a try if the AMD one doesn't work?
    Whichever graphics card driver I end up with, I'm guessing that I still ought to get the "OpenCL Runtime for Intel Core and Intel Xeon Processors" (16.1.1 or later); since the CPU is a CORE i5?
I think you missed the most important line within my previous reply i.e. "use ubuntu, not The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali)!"

If you still insist in using The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali) (which fails to allow the user to use hashcat because of those crappy package dependencies etc), you could try to use this guide at your own risk: (this is for nvidia GPUs, you might need to adapt it slightly to get AMD GPUs working)

It is a mess and you will struggle for sure to get everything working (we also can't hold hands to help you set up hashcat with a distribution that doesn't care at all about the problems we have reported a couple of times with no avail).

So either you use ubuntu, install the drivers and download hashcat from and just run it .... or continue to mess around on your own (well actually I already did the hard work for you, it was a pain I tell you!) to get The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali) run hashcat correctly. It's you choice.

And to be clear, this is not a problem of hashcat, nor a problem of your hardware or the drivers. It's The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali)'s fault.

This is also why K A L I is replaced by The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali) within this forum

Furthermore, we do not recommend to run hashcat on a notebook (for obvious reasons, heat etc), mobile GPUs are shitty and it might be also a (very/too) old GPU you have (a 6xxxM series, please use modern Nvidia GPUs like the 1080 ti).