New bug
I got this using version 0.20 and replicated in version 0.21. I was doing an attack with 2 dictionary combined and I got many cracked hashes like if they were empty passwords but they are not. I don't know the exact passwords so I can't tell what it is supposed to be. The first dictionary contains some symbols like quotation mark. I suspect that if a password start with one of them (symbol), it might cause this behavior. Here's some Hash:Salt that gives the bug:

need a dictionary to reproduce. you are using -m 2 mode?
(07-02-2010, 07:34 AM)atom Wrote: need a dictionary to reproduce. you are using -m 2 mode?
Yes, it was mode 2 on OclHashcat. One of the dictionaries is about 100 Mb so I don't think I could attach it to a post. I am currently trying to find the real password of some of those hashes with PasswordsPro but it's combinatory attack is quite slow on 1 CPU.
ok. i also tried it with some of my dictionaries but none of them found a password.
root@sf:~/oclHashcat-0.22# echo aaa > word
root@sf:~/oclHashcat-0.22# cat word
root@sf:~/oclHashcat-0.22# echo -n aaaaaaaaa | md5sum
552e6a97297c53e592208cf97fbb3b60 -
root@sf:~/oclHashcat-0.22# echo 552e6a97297c53e592208cf97fbb3b60 > hash
root@sf:~/oclHashcat-0.22# cat hash
root@sf:~/oclHashcat-0.22# ./oclHashcat64.bin -m 1 hash word word -e word -o x
root@sf:~/oclHashcat-0.22# cat x
root@sf:~/oclHashcat-0.22# ./oclHashcat64.bin -m 2 hash word word -e word -o x
root@sf:~/oclHashcat-0.22# cat x

hm, looks good for me
I will try the following in order to isolate the bug. I will split the 100 Mb dictionary in several small ones and try them until one of the hashes is cracked. Then I will split that specific subdictionary in small parts until it reach a size that I can post. What is the maximal size of attachment?
not sure. if it does not fit, use rapidshare or something similar
Well, I really don't know what's going on. I was not able to reproduce the problem with the split dictionary so I tried the previous full attack and was not able to reproduce it again. Hashcat was running at the same time as OclHascat the last time I had the bug so I tried that as well without success. I have no clue what happened between yesterday and today. I will repost If I figure out what triggered it but there's nothing to be done right now.
anyway, thanks for reporting! i will also keep an eye on it.