hashcat approved gpu driver no longer available
The web page here: https://hashcat.net/hashcat/

... says Windows users need 'AMD Radeon Software Crimson Edition (15.12 or later)', but AMD are not hosting this any more. Instead they direct me to download their 'Radeon Software Adrenalin Edition Graphics Driver Installer for Windows 10 64-Bit'. (https://support.amd.com/en-us/download)

Can anybody confirm the Adrenalin driver works for Hashcat?
Unknown. Too bad we don't have any tester with AMD + windows combination anymore. Almost everyone switched to nvidia or linux or both.
Thank you for your reply Atom. I'm a linux user, but I didn't get any joy using the Ubuntu Server 14.04 LTS instructions here:

I'll try the Adrenaline driver on Windows, and if it doesn't work, I'll have a crack again with linux. Going to take a while though, so busy with other stuff :-O

Again, thank you for your reply Smile
wow, shouldn't we just delete that ancient and outdated wiki article? Please, nobody, use ubuntu 14.04 anymore.
Yeah, we should. But then there's nothing left.
(08-07-2018, 02:18 PM)atom Wrote: Yeah, we should. But then there's nothing left.

Someone could piece together the instructions for Ubuntu 16 and add that to the wiki.

I did some of that previously in these threads:


The guide from evilmog for Ubuntu 16 is probably still useable.  It can be seen here:

One of these days, I will have to build a new rig from scratch with Ubuntu 18 and document the process.  By the time I get around to it, 19 will probably be out.

Hope this helps.
My experience:
System with Linux (Debian9) + Nvidia
This guide did the trick (+ some finetuning) without any problems. (Comparable with evilmog's explanation, found here, as stated by devilsadvocate)

System with Win10 + AMD
A lot of headache on this one.
Finally, a manual downgrade of the AMD driver (from 18.x to 16.x) and a manual forced install did the trick. Win10 driver-auto-update needs to be disabled in order to avoid a driver-update on each reboot.

System with Linux + AMD
A lot of headache on this one. 
The rocm driver (as explained here by atom) worked only for one card. Other cards were rejected by driver "kfd kfd: skipped device 1002:67df, PCI rejects atomics"
Not found a solution till now.
What exactly is the problem with Win10 + AMD? Maybe we can make it possible!
Win10 + AMD
- After installing latest driver from AMD-website (Adrenalin edition v18.x), the cards (RX570) where detected by the system, drivers were correctly installed, but cards didn't work; in device manager I saw that they were turned off by Win10 because of 'driver issue'; (can't remember exactly what error-code)
- After cleaning, I downloaded old drivers v16.x (supposed for RX4xx) and forced Win10 to use this one
- Disabled driver auto-update to avoid reinstall to more recent driver by Win10
I am Using Windows 10 1803. Radeon R9 390X (6 of them) Adrenalin 18.10.1 AMD driver and I also get the same thing.
running example0.cmd
In the command prompt I get:
Starting hashcat 4.2.1
<all the video cards and hardware>
Minimum password length supported by kernel: 0
Maximum '' : 256
WatchDog: Temperature abor trigger set to 90c
Initializing device kernels and memory...
Then I'm back with it waiting for me to put in command again. So hashcat closed but the command prompt remained opened.
Tried Crimson ReLive 17.11.1. Same thing