hashcat says no driver installed HELP
#1
hello, trying to run hashcat, which give me this error:

/Downloads/hashcat-4.2.1$ ./hashcat64.bin -b -m 2500
hashcat (v4.2.1) starting in benchmark mode...

Benchmarking uses hand-optimized kernel code by default.
You can use it in your cracking session by setting the -O option.
Note: Using optimized kernel code limits the maximum supported password length.
To disable the optimized kernel code in benchmark mode, use the -w option.

Cannot find an OpenCL ICD loader library.

You are probably missing the native OpenCL runtime or driver for your platform.

* AMD GPUs on Linux require this runtime and/or driver:
  "RadeonOpenCompute (ROCm)" Software Platform (1.6.180 or later)
* Intel CPUs require this runtime and/or driver:
  "OpenCL Runtime for Intel Core and Intel Xeon Processors" (16.1.1 or later)
* Intel GPUs on Linux require this runtime and/or driver:
  "OpenCL 2.0 GPU Driver Package for Linux" (2.0 or later)
* NVIDIA GPUs require this runtime and/or driver:
  "NVIDIA Driver" (367.x or later)

But nvidia driver is INSTALLED!

inxi -SGx
System:    Host: m3n Kernel: 4.15.0-34-generic x86_64 bits: 64 gcc: 7.3.0
           Desktop: Gnome 3.28.3 (Gtk 3.22.30-1ubuntu1) Distro: Ubuntu 18.04.1 LTS
Graphics:  Card-1: Intel Device 3e92 bus-ID: 00:02.0
           Card-2: NVIDIA GP102 [GeForce GTX 1080 Ti] bus-ID: 01:00.0
           Card-3: NVIDIA GP102 [GeForce GTX 1080 Ti] bus-ID: 02:00.0
           Display Server: x11 (X.Org 1.19.6 ) driver: nvidia Resolution: 2560x1440@59.95hz
           OpenGL: renderer: GeForce GTX 1080 Ti/PCIe/SSE2 version: 4.6.0 NVIDIA 390.87 Direct Render: Yes


nvidia-smi
Thu Sep 13 02:23:34 2018       
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 390.87                 Driver Version: 390.87                    |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  GeForce GTX 108...  Off  | 00000000:01:00.0  On |                  N/A |
| 29%   44C    P0    60W / 250W |    264MiB / 11178MiB |      0%      Default |
+-------------------------------+----------------------+----------------------+
|   1  GeForce GTX 108...  Off  | 00000000:02:00.0 Off |                  N/A |
| 23%   27C    P8     8W / 250W |      2MiB / 11178MiB |      0%      Default |
+-------------------------------+----------------------+----------------------+
                                                                               
+-----------------------------------------------------------------------------+
| Processes:                                                       GPU Memory |
|  GPU       PID   Type   Process name                             Usage      |
|=============================================================================|
|    0      2167      G   /usr/lib/xorg/Xorg                           162MiB |
|    0      2306      G   /usr/bin/gnome-shell                          99MiB |
|    0      2658      G   /usr/bin/nvidia-settings                       0MiB |
+-----------------------------------------------------------------------------+


i can change the fan speed of fan:

sudo nvidia-settings -a "[gpu:0]/GPUPowerMizerMode=1" \
    -a "[gpu:0]/GPULogoBrightness=0" \
    -a "[gpu:0]/GPUFanControlState=1" \
    -a "[fan:0]/GPUTargetFanSpeed=100"

But why hashcat complaining no nvidia driver?
Reply
#2
Try this:

Code:
apt-get install ocl-icd-libopencl1 opencl-headers clinfo
Reply