ATTENTION! OpenCL kernel self-test failed.
Please take a look at a671d50 from 14th of April (

Rigged stand with HD7770 (Capeverde), AMD driver 26.20.15002.61 and OpenCL 2.1 AMD-APP (3004.7) under Win7x64, compiled hashcat with cygwin's gcc.

Commits before said one are ok, solving test WPA-EAPOL-PBKDF-2 as expected. Starting from a671d50 hashcat returns "OpenCL kernel self-test failed" error (recent builds return just yellowish "wrong driver", no "self-test failed" red banner).

Now, I didnt check if --self-test-disable actually solves hash or not for all those builds I went through. I tested it once with most recent commit from 20.12 and it didnt. From there I just tested if build returns self-test/wrong driver error or actually works as expected and solves the hash.

Hope it helps. I preserved testing environment, stand will be available for re-runs at least for several days so poke me if you need any extra action.
wow, that's a great discovery (altrough it still doesn't make much sense.. maybe driver bug?)

could you please first test the latest git version without any modification (fresh clone, make clean, git checkout master, git pull, make). when testing, in general, do not forget the make clean, git pull or checkout, and make

after that fails, could you try to make clean and download the patch you mentioned:

and use
git apply -R a671d501aab08cd24308a7d253d7bc3b9ff5919a.diff

and make again and test.
Thank you so much

note: latest code change a lot again and we "only" use -m 22000 and 22001 for WPA in the future (as replacements for -m 2500/2501 and alternatives)
@ philsmd
latest tests of 22000 - WPA-PBKDF2-PMKID+EAPOL are very impressive. 2200x offers many advantages.
(12-22-2019, 12:36 PM)philsmd Wrote:
git apply -R a671d501aab08cd24308a7d253d7bc3b9ff5919a.diff

Yes, reverse-patched build worked!

Exact log of what I did:
mkdir requested-run
cd requested-run/
git clone
cd hashcat/
make clean
git checkout master
git pull

Copied compiled build outside cygwin, added cygwin' dlls and and executed as such:
hashcat.exe -w3 -m 2500 test.hccapx -a 3 0?d?d?d?d?d?d?d --status
=> Your device driver installation is probably broken.

Same result for -m22000

Back to cygwin, /home/root/requested-run/hashcat:

make clean

Copied patch from outside of cygwin into /home/root/requested-run/hashcat (didnt install wget)

git apply -R a671d501aab08cd24308a7d253d7bc3b9ff5919a.diff

=> no output


Copied compiled build outside cygwin (new directory, no merging), added cygwin' dlls and and executed as such:
hashcat.exe -w3 -m 2500 test.hccapx -a 3 0?d?d?d?d?d?d?d --status
=> Cracked

Same result for -m22000
Hey fromdusktillpwn,

thank you again for this amazing troubleshooting and testing. We appreciate this very much, because we know this can be kinda tedious to test all the commits and find the right one (and always have to make sure that you are testing correctly, with make clean etc)... This is such a great find. Thank you very much!

I've explained your discoveries of course also to atom (main developer of hashcat) and we are currently testing/debating if we can revert this change without any significant disadvantages (other problems or significant speed losses with other setups/GPUs and or problems with macOS/linux drivers etc).

To make the "best" decision it would also be very helpful if we knew if this change would fix also the problem of the original reporter "slawson" because s/he stated that "I have tried Hashcat 5.1, 5.0, & 4.2.1" in the first post of this thread ( )... which would be kinda different (or even contradictory) to the discovery that we made here: "only" beta/git versions after 14th of April are affected.

I think it would make sense to try to get an answer from slawson too, but if we do not find any regression with the reverted patch, we should definitely revert this change.
Thank you again !

we just updated the source code to make the changes that fromdusktillpwn tested ( that should "fix" the problem. Please test the beta version from and report back. any feedback could help. thanks
Windows 10
Dual AMD R9-290x
AMD Driver 8/16/19 26.20.12028.2

I have tested and verified that the following beta versions work correctly with -m2500.


As an added bonus, I seem to be squeezing about 10-20 more kH/s with +1523.
Thanks for the update. I'm still confused about the fact that it now seems to work for you with different beta versions (NOT just with the latest one) and that your original post says that even older versions of hashcat didn't work...
maybe we can somehow find out what is going on here and if these are different kind of problems we are looking at here.

What do your setups have in common and what is different ? Why should one system only work with latest beta and the other works with older betas (that should have the same problem)?
If I can provide any more information or help, just let me know.

Merry Christmas to all!
Earned !!!
You are on the right track.
And productivity has increased.

[Image: 814893946c6527ad62bc1f38325f6d11.jpg]
Yes, +1523 works.

So far I got this table:

[Image: 2fcda284620b302913fdd184bece6bd7.png]

Both chipsets started year with error, +605 fixed it for some combinations, +622 fixed for the rest, +914 broke for some again and +1520 fixed it back. Coulbe be two separate issues.