Newer windows build
I'm using version 5.1.0 on Windows and when I try to use mode -m 19900 it says this is an unrecognised mode. So I figured I must need to update to a newer version but it looks like there are no newer binary releases than 5.1 which was released back in 2018.

So I tried downloading from github and building myself with cygwin, following the instructions in the readme. 

Build went fine but when I try and run it (either from the cygwin terminal or from cmd.exe) I get this:

hashcat (v5.1.0-1705-gfdde629d) starting...
/usr/bin/OpenCL/: No such file or directory

I'm assuming this needs more than just creating a directory to get it working properly, but before I go looking into all that I'm just wondering why this behaves so differently to the hashcat32.exe or hashcat64.exe that I originally downloaded? Like how were the originals built so that they didn't need cygwin, and why is this version requiring a folder to exist that the original 5.1.0 version I was using didn't need? 

Are there any plans to build another main release any time soon that "just works" on Windows in the same way that the 5.1.0 release on the main website does?


Heres the proper beta files, just extract and try with this.
(02-23-2020, 04:43 AM)slyexe Wrote:

Heres the proper beta files, just extract and try with this.

That worked perfectly thanks! Much appreciated.

Out of curiosity, how would I have found that on the main website or github? All the files on the website are listed as being from 2018. 

Also I still don't really understand how this main executable is built to work without requiring cygwin or anything like that, yet when we build it ourselves it does.