Radeon Vega 64 Compatible? OpenCl Self-Test Failed
I previously experimented with Hashcat to try to crack a WPA Handshake that I had already acquired using my NVIDIA 750TI graphics card, using a mask attack with just all uppercase characters only, 8 characters in length.  Hashcat reported no problems and started to run at about 56,000 hashes per second with an estimated completion time of around 37 days.

So I thought hmm could do with a better graphics card anyway and searching for benchmark tests online found I could get much faster with a better card.  So bought a RADEON Vega 64 second hand as got one for a reasonable price and didn't want to spend a fortune on a new card. So I started by installing the latest driver Adrenalin 20.2.1

I then ran a benchmark test i.e. 'Hashcat64.exe -b', but when it gets to the 2500 type, which i believe is the hash type for a WPA handshake that I need, I get the following error :-

Attention! OpenCL kernel Self-test failed - Your device driver installation is probably broken

I also noticed the mouse icon on the screen kept displaying the circle on and off as if it was loading something.

So looked through forums to try to find a solution and people were saying it was something to do with AMD not supporting OpenCL and others saying problems with their latest drivers. Someone else said to type --Self-Test-Disable to force it to continue.

I did this and seemed to run OK, reporting a much higher 467,000 hashes per second with only around 5 days to complete. However someone also said that it will not find it even if it appears to be running.

So I removed the AMD driver and installed an earlier version 19.9.2 but same problem. (Noticed I don't get the circle flashing around the Mouse Icon anymore)

Also found forum where they said to use the Beta version of Hashcat which I did but I still get the same problem

So my question is this. First will it still find the password (assuming it is an 8 character, upper case characters only that iv'e set Hashcat to only look for) running the Self Test Disable? Or will Hashcat not work with this AMD card? Is there a workaround? Can't find a solution online

Wasn't sure if to sell it and buy an AMD one such as the NVIDIA Geforce GTX 1080, which I can get for a similar price
have you tried the latest driver + hashcat beta?
I think so it was AMD's website version Adrenalin 20.2.1. And I used a link for the Hashcat Beta. So when I type Hashcat -V to display the version it says v5.1.0-1736-gb1d5f92c. Is this the Beta version.
I have no trouble with -m 2500 on Vega 20 (Radeon VII) and a build of hashcat from git, using ROCm on Linux. I had to build from master to solve this problem in 5.1.0.

$ hashcat -d 2 -b -m 2500
hashcat (v5.1.0-1536-g7215d4e9) starting in benchmark mode...

Benchmarking uses hand-optimized kernel code by default.
You can use it in your cracking session by setting the -O option.
Note: Using optimized kernel code limits the maximum supported password length.
To disable the optimized kernel code in benchmark mode, use the -w option.

/usr/local/share/hashcat/OpenCL/m02500-optimized.cl: Optimized kernel requested but not needed - falling back to pure kernel
OpenCL API (OpenCL 2.1 AMD-APP (3052.0)) - Platform #1 [Advanced Micro Devices, Inc.]
* Device #1: gfx906+sram-ecc, skipped
* Device #2: gfx906+sram-ecc, 16256/16368 MB (13912 MB allocatable), 60MCU
* Device #3: gfx906+sram-ecc, skipped
* Device #4: gfx906+sram-ecc, skipped

Benchmark relevant options:
* --backend-devices=2
* --optimized-kernel-enable

Hashmode: 2500 - WPA-EAPOL-PBKDF2 (Iterations: 4095)

Speed.#2.........:   598.1 kH/s (50.97ms) @ Accel:32 Loops:256 Thr:256 Vec:1

Started: Tue Mar 10 21:26:40 2020
Stopped: Tue Mar 10 21:28:44 2020
Using the latest Adrenaline driver (20.4.2) and the latest hashcat beta (v5.1.0-1795-g08ea0002) works now fine on my Windows 10 system with a Vega64.
When using the latest stable hashcat version (5.10) I get a kernel self-test failure when using -m 2500.