release 0.15 froze
#1
Came across a strange issue

Running SHA1 combo attack with a small left list and a large right list

3/4 of the way through it froze. System didn't freeze but the process oclhashcat process did.

GPUs were not at full load since it was tuned to 8 from 80 as there wasn't enough work from the left list.

Session.Name...: oclHashcat-plus
Status.........: Running
Input.Base.....: File (..\..\speciallist\search1.txt)
Input.Mod......: File (..\..\speciallist\blazer\06)
Hash.Target....: File (..\SHA1\hashes.txt)
Hash.Type......: SHA1
Time.Started...: Sun Aug 25 13:57:58 2013 (38 mins, 14 secs)
Time.Estimated.: Sun Aug 25 14:47:28 2013 (11 mins, 14 secs)
Speed.GPU.#1...: 1284.4 MH/s
Speed.GPU.#2...: 132.0 MH/s
Speed.GPU.#*...: 1416.4 MH/s
Recovered......: 91/859360 (0.01%) Digests, 0/1 (0.00%) Salts
Progress.......: 3328400373504/4307174416710 (77.28%)
Rejected.......: 0/3328400373504 (0.00%)
HWMon.GPU.#1...: 74% Util, 68c Temp, 87% Fan
HWMon.GPU.#2...: 85% Util, 46c Temp, 39% Fan

There is the spot it has frozen at.
Drivers: 13.4
Cards: 7970 + 5850

I know it's a bit vague but will post again if the issue arises again.
Reply
#2
Is this reproducable? Does it freeze every time at the same spot? Else I'll go ahead and claim defective hardware/overheating problem.
Reply
#3
I noted the same behavior, with same drivers, cards 2 x 6990.
Not a problem with 016.b53, but the recent 0.15 and 0.16b72, b73
and b82 have the same behavior.
Didn't report as it could be a problem from my own side, hardware
or something else... Now that I see blazer report...
Didn't tested SHA1, but noted immediately with MD5.
Reply
#4
Same problem described happened to me.

OS 7 x64
5850 + 5770
Cat 13.8 beta v1

OCLhc 0.15 stable

Attack -a 0 + best64

Hashset: ~1000 hashes.
Reply
#5
there is beta2 up, try again please
Reply
#6
Beta2, cat 13.4
After this crash, running the same command line once, no error (at least, when trying one more time).
Using a folder with multiple dictionaires freezes again or crash.

http://imgbox.com/ablg6EvO
Reply
#7
(08-28-2013, 10:46 PM)proinside Wrote: Beta2, cat 13.4
After this crash, running the same command line once, no error (at least, when trying one more time).
Using a folder with multiple dictionaires freezes again or crash.

http://imgbox.com/ablg6EvO
I get this (oclhashcat64.exe has stopped working) often too. It seems to me that it's almost always near the end of an attack. I get also the following error: clenqueuewritebuffer() -30

In my case it was in windows7 64bit catalyst 13.8beta and on oclhashcat version 1.00b3.
Reply
#8
those threading semaphores gave us some headaches. try new beta4 please
Reply
#9
(08-29-2013, 11:18 AM)atom Wrote: those threading semaphores gave us some headaches. try new beta4 please
Looks like the crashes are solved. When my attacks will finish, I will test the freezes on bruteforce/mask attacks.
Reply
#10
@mastercracker please have also a look at my comment in https://hashcat.net/trac/ticket/82 , I think those changes we made recently fixed that problem (too)

Can you please run the exact same commands (w/ bat and/or hcmask) and close the ticket if it was fixed?

Thx
Reply