Automated Tests for Beta Testers
#11
(11-29-2013, 04:04 PM)mastercracker Wrote: While running the test.sh file (command line: bash test.sh -b nvidia -x 64 -o win), I get the error:
Code:
Can't open perl script "tools/test.pl": No such file or directory
A new test folder was created with all empty files except the logfull.txt. The perl error is not mentioned in the logfull.txt (which is renamed test_report_nvidia.log once the script is completed). What I get in the logfull/test_report file is:
Code:
ERROR: hashfile is empty or corrupt
Which makes sense since all the files created in the new folder were empty.

EDIT: Also there were no perl script or tools folder in the package that I have downloaded from the beta section.

Ah stop, don't make it more complicated as it is. There is a package test_1385640930.7z in https://hashcat.net/beta/

Simply unpack it. Inside this package is a test.sh which is to be run. It will take the precompiled hashes that are part of the package. There is no need to have perl installed.
Reply
#12
Darn. Stupid me. Here's the couple of stupid things not to do:

1) Put all the files of the test folder in the same directory as the oclhashcat binaries, cd to that folder in cygwin and try to run the test.sh.
2) Put the test folder in oclhashcat's folder (good so far), cd to the test folder in cygwin and try to run it from there (wrong).

What I was supposed to do and which was properly explained by Atom in his first post is to:

Put the test folder in oclhashcat's folder, cd to the oclhashcat's folder in cygwin and run test.sh using the path leading to the test folder.

Code:
test_1385640930/test.sh -b nvidia -x 64 -o win

Will post results when the test is over.
Reply
#13
RESULTS
--------------

Spec:
6 x MSI 7970 3GB Edition. Standard Clocks
24GB RAM
AMD 6-core 3.0Ghz CPU
SSD 512GB disk

* -d 1 was removed from the command-line, so all 6 were used if load was enough*

NOT FOUND
-----------------------
password not found, cmdline : ./oclHashcat64.bin --quiet --force --disable-potfile --runtime 200 --gpu-temp-disable -a 3 -m 1800 '$6$0752557702004502$j1piinL8KAPK9VlzWw8jpDOBnn5ueJBIpjPXCFxOr03qEmTo4QoFMQlqxc.nYsVGLyq2LKGvACtFoxXHrzX/E1' ?d?d?d?d
password not found, cmdline : ./oclHashcat64.bin --quiet --force --disable-potfile --runtime 200 --gpu-temp-disable -a 3 -m 1800 '$6$2102463701172173$yHpTcJBncuvI92TSifsKttX91.uKw3r0ryNcyA7P7HnfiXJAkFDysz7NKExD8PoS4eYheUu9US9H/2rcyX18p1' ?d?d?d?d?d
password not found, cmdline : ./oclHashcat64.bin --quiet --force --disable-potfile --runtime 200 --gpu-temp-disable -a 3 -m 1800 ./test_1385640930//1800_multihash_bruteforce.txt ?d?d?d?d?d?d?d?d --increment --increment-min 1 --increment-max 8
password not found, cmdline : ./oclHashcat64.bin --quiet --force --disable-potfile --runtime 200 --gpu-temp-disable -a 3 -m 3200 '$2a$05$LxeyLxevLRWzKBW0MBOvLuYt5uXhAR.w4CkAxxy6JjpQvNyml10gC' ?d?d?d
password not found, cmdline : ./oclHashcat64.bin --quiet --force --disable-potfile --runtime 200 --gpu-temp-disable -a 3 -m 3200 ./test_1385640930//3200_multihash_bruteforce.txt ?d?d?d?d?d?d?d?d --increment --increment-min 1 --increment-max 8
password not found, cmdline : ./oclHashcat64.bin --quiet --force --disable-potfile --runtime 200 --gpu-temp-disable -a 3 -m 7400 '$5$3372373318373648$s8OgrOmu9ZeqV4.teCTjBHvTNqwtRo.syoFn56L/mv6' ?d?d?d?d
password not found, cmdline : ./oclHashcat64.bin --quiet --force --disable-potfile --runtime 200 --gpu-temp-disable -a 3 -m 7400 '$5$0544664680478613$l3/qg9pN6JlStw6V1c7dFReQZ.8.MtyM7hDZzU/bZo1' ?d?d?d?d?d
password not found, cmdline : ./oclHashcat64.bin --quiet --force --disable-potfile --runtime 200 --gpu-temp-disable -a 3 -m 7400 ./test_1385640930//7400_multihash_bruteforce.txt ?d?d?d?d?d?d?d?d --increment --increment-min 1 --increment-max 8

The errors seem to be the fact that hashcat runs through the whole mask and does not find a match. There were no actual application errors. It just didn't find it.

ERRORS
---------------------
None
Reply
#14
@rurapenthe , could you please double-check if those errors do not happen if you keep the -d 1....

note: you can run the test also as: test_1385640930/test.sh -m 1800 -a 3 -t single # for example

or just run the command above w/ -d 1 added i.e:
./oclHashcat64.bin --quiet --force --disable-potfile --runtime 200 --gpu-temp-disable -a 3 -m 1800 -d 1 '$6$0752557702004502$j1piinL8KAPK9VlzWw8jpDOBnn5ueJBIpjPXCFxOr03qEmTo4QoFMQlqxc.​nYsVGLyq2LKGvACtFoxXHrzX/E1' ?d?d?d?d

I'm not sure if this is a multi-gpu problem, we need to investigate.
there should be no exhausted case in the test either.
my output is btw:
$ ./oclHashcat64.bin --quiet --force --disable-potfile --runtime 200 --gpu-temp-disable -a 3 -m 1800 '$6$0752557702004502$j1piinL8KAPK9VlzWw8jpDOBnn5ueJBIpjPXCFxOr03qEmTo4QoFMQlqxc.nYsVGLyq2LKGvACtFoxXHrzX/E1' ?d?d?d?d
$6$0752557702004502$j1piinL8KAPK9VlzWw8jpDOBnn5ueJBIpjPXCFxOr03qEmTo4QoFMQlqxc.nYsVGLyq2LKGvACtFoxXHrzX/E1:2472

therefore, this should be crackable w/ that mask
Reply
#15
UPDATE
----------

All now PASS if i use -d 1

So no errors, and no not found Smile



(11-30-2013, 11:34 AM)philsmd Wrote: @rurapenthe , could you please double-check if those errors do not happen if you keep the -d 1....

note: you can run the test also as: test_1385640930/test.sh -m 1800 -a 3 -t single # for example

or just run the command above w/ -d 1 added i.e:
./oclHashcat64.bin --quiet --force --disable-potfile --runtime 200 --gpu-temp-disable -a 3 -m 1800 -d 1 '$6$0752557702004502$j1piinL8KAPK9VlzWw8jpDOBnn5ueJBIpjPXCFxOr03qEmTo4QoFMQlqxc.​nYsVGLyq2LKGvACtFoxXHrzX/E1' ?d?d?d?d

I'm not sure if this is a multi-gpu problem, we need to investigate.
there should be no exhausted case in the test either.
my output is btw:
$ ./oclHashcat64.bin --quiet --force --disable-potfile --runtime 200 --gpu-temp-disable -a 3 -m 1800 '$6$0752557702004502$j1piinL8KAPK9VlzWw8jpDOBnn5ueJBIpjPXCFxOr03qEmTo4QoFMQlqxc.nYsVGLyq2LKGvACtFoxXHrzX/E1' ?d?d?d?d
$6$0752557702004502$j1piinL8KAPK9VlzWw8jpDOBnn5ueJBIpjPXCFxOr03qEmTo4QoFMQlqxc.nYsVGLyq2LKGvACtFoxXHrzX/E1:2472

therefore, this should be crackable w/ that mask
Reply
#16
Windows 7 64
catalyst 13.9
cygwin

Does not seem to be an oclHastcat error to me, but here it is:

Code:
[ len 11 ] ERROR: cannot open '{ssha512}06$4818543662046424$nLXETd7BMlvBpunnC2OEKIiKZpkpENAC4T3wVneRlxTAfInv6dN93lS8tYg00UNrN6OdXfJKb7M.6WwJ.NP/..' (13) : Permission denied^M
! unhandled return code 127, cmdline : echo -n 10471161328 | ./oclHashcat64.exe --quiet --force --disable-potfile --runtime 200 --gpu-temp-disable -d 1 -a 0 -m 6500 '{ssha512}06$4818543662046424$nLXETd7BMlvBpunnC2OEKIiKZpkpENAC4T3wVneRlxTAfInv6dN93lS8tYg00UNrN6OdXfJKb7M.6WwJ.NP/..' $

[ len 11 ] ERROR: cannot open '{ssha512}06$4818543662046424$nLXETd7BMlvBpunnC2OEKIiKZpkpENAC4T3wVneRlxTAfInv6dN93lS8tYg00UNrN6OdXfJKb7M.6WwJ.NP/..' (13) : Permission denied^M
! unhandled return code 127, cmdline : ./oclHashcat64.exe --quiet --force --disable-potfile --runtime 200 --gpu-temp-disable -d 1 -a 1 -m 6500 '{ssha512}06$4818543662046424$nLXETd7BMlvBpunnC2OEKIiKZpkpENAC4T3wVneRlxTAfInv6dN93lS8tYg00UNrN6OdXfJKb7M.6WwJ.NP/..' test_1385640930//6500_dict1 test_1385640930//6500_dict2 $
Reply
#17
"Bug" reproduced on the Nvidia side. Windows 7, 64 bit, Driver 320.49, GTX470

Code:
[ len 11 ] ERROR: cannot open '{ssha512}06$4818543662046424$nLXETd7BMlvBpunnC2OEKIiKZpkpENAC4T3wVneRlxTAfInv6dN93lS8tYg00UNrN6OdXfJKb7M.6WwJ.NP/..' (13) : Permission denied^M
! unhandled return code 127, cmdline : echo -n 10471161328 | ./cudaHashcat64.exe --quiet --force --disable-potfile --runtime 200 --gpu-temp-disable -d 1 -a 0 -m 6500 '{ssha512}06$4818543662046424$nLXETd7BMlvBpunnC2OEKIiKZpkpENAC4T3wVneRlxTAfInv6dN93lS8tYg00UNrN6OdXfJKb7M.6WwJ.NP/..' $

and

[ len 11 ] ERROR: cannot open '{ssha512}06$4818543662046424$nLXETd7BMlvBpunnC2OEKIiKZpkpENAC4T3wVneRlxTAfInv6dN93lS8tYg00UNrN6OdXfJKb7M.6WwJ.NP/..' (13) : Permission denied^M
! unhandled return code 127, cmdline : ./cudaHashcat64.exe --quiet --force --disable-potfile --runtime 200 --gpu-temp-disable -d 1 -a 1 -m 6500 '{ssha512}06$4818543662046424$nLXETd7BMlvBpunnC2OEKIiKZpkpENAC4T3wVneRlxTAfInv6dN93lS8tYg00UNrN6OdXfJKb7M.6WwJ.NP/..' test_1385640930//6500_dict1 test_1385640930//6500_dict2 $
Also these 2 but they were caused by the --runtime 200. Without the --runtime, they get cracked:
Code:
timeout reached, cmdline : ./cudaHashcat64.exe --quiet --force --disable-potfile --runtime 200 --gpu-temp-disable -d 1 -a 3 -m 400 test_1385640930//400_multihash_bruteforce.txt ?d?d?d?d?d?d?d?d --increment --increment-min 1 --increment-max 8

and

timeout reached, cmdline : ./cudaHashcat64.exe --quiet --force --disable-potfile --runtime 200 --gpu-temp-disable -d 1 -a 3 -m 6500 test_1385640930//6500_multihash_bruteforce.txt ?d?d?d?d?d?d?d?d --increment --increment-min 1 --increment-max 8
Reply
#18
(11-30-2013, 12:41 PM)rurapenthe Wrote: UPDATE
----------

All now PASS if i use -d 1

So no errors, and no not found Smile
Well, not really. If it does not work with multi-GPU, it's not OK.
Reply
#19
In my case, I just did the full test with 1 x GTX470 and 2 x GTX460 on the same setup posted above for the GTX470 and everything is the same (all good except the 2 -m 6500 hashes).
Reply
#20
All OK for me:
Linux 3.12 (Ubuntu) x64
VTX 7970 AMD drivers 13.11 beta
Reply