AMD-ATI driver a bit help needed
Hi, this is my first post here (i was recomended to come here by md5decrypter forum)
so here it goes:

As you might know The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali) linux 3.12 (as well as other Debian distros) are having serious trouble with the current Catalyst 13.251 installation as it doesn't even compile.

I managed to fix that (That patch can now be found anywhere)
--- kcl_acpi.c
+++ kcl_acpi.c
@@ -995,7 +995,11 @@
         return KCL_ACPI_ERROR;
-    }    
+    }
+    ((acpi_tbl_table_handler)handler)(hdr);
     return KCL_ACPI_OK;

But that wasn't enough. I kept getting this "deprecated" messages (that i know is not an error its self but still anoying)

Fixed that to by doing an (if im in the unpacked installation directory
echo 5 > ./packages/Debian/dists/etch/compat  
echo 5 > ./packages/Debian/dists/experimental/compat
echo 5 > ./packages/Debian/dists/lenny/compat
echo 5 > ./packages/Debian/dists/sid/compat

When i did that i figured there was a serious mistake in the Xorg server as The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali)(mine at least)
had both the X11 and the X11R6 which means serious mistakes are going to happened

i fixed that as well
ln -s /usr/bin/X11  /usr/X11R6/bin
ln -s /usr/lib/X11  /usr/X11R6/lib64/X11

After that i still kept getting errors ...
Missing directories here , there just catastophic errors.
I dig into 1500 lines of code that brought me to ./ati-packager in debian distro which was probably just copied from the old version of drivers. So the errors were kinda like this one
cp: cannot stat `/home/My_name/Tools/AMD_Driver/fglrx-install.yX7BZQ/x710_64a/*': No such file or dir

Fixed it too ( if anyone is interested i can post the fixed code)

Then got into some serious mixed libraries..
one error is
error: couldn't find library needed by debian/fglrx-driver/usr/lib/xorg/modules/linux/

It can be fixed with no problem since i know there is a in the installation directory
# change dir untill  in ./intallationdir/arch/x86_64/usr/lib64/
ln -s
#change dir untill in ./intallationdir/arch/x86/usr/lib/
ln -s

That fixed allot of problems but there are still some and im kinda tired and off to sleep.
the problem is
# previous code that probably succeded
ldconfig -n usr/X11R6/lib/
dh_install -pfglrx-driver "usr/X11R6/bin/fgl*"      "usr/bin"
dh_install -pfglrx-driver "usr/X11R6/bin/aticonfig" "usr/bin"
dh_install -pfglrx-driver "usr/sbin/atieventsd"     "usr/sbin"
dh_installman -pfglrx-driver "usr/share/man/man8/atieventsd.8"
# amd64 needs some library redirection
dh_install -pfglrx-driver "usr/X11R6/lib64/*.so*"           "usr/lib"
dh_install -pfglrx-driver "usr/X11R6/lib64/modules/dri"     "usr/lib"
dh_install -pfglrx-driver "usr/X11R6/lib64/modules/linux"   "usr/lib/xorg/modules"
dh_install -pfglrx-driver "usr/X11R6/lib64/modules/drivers" "usr/lib/xorg/modules"
dh_install -pfglrx-driver "usr/X11R6/lib64/modules/extensions" "usr/lib/xorg/modules"
dh_install -pfglrx-driver "usr/X11R6/lib64/modules/*.so"    "usr/lib/xorg/modules"
dh_install -pfglrx-driver "usr/X11R6/lib64/modules/*.a"     "usr/lib/xorg/modules"
dh_install: fglrx-driver missing files (usr/X11R6/lib64/modules/*.a), aborting
make: *** [binary] Error 255
dpkg-buildpackage: error: debian/rules binary gave error exit status 2
+ rm -rf /tmp/fglrx.fyOOzM
+ rm -f /tmp/pkg_build.out
+ exit 1

this is the debug of the

So still somewhere the libraries are not all in order.
Probably some symlinking needed. Any ideas are more than welcome

I tried this with philsmd, and we never got this to work then i switched to Ubuntu 13.10 64 bit and installed the BETA driver and it worked fine, then i just installed all of The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali)'s tools through Synaptic.

But we ended up with a solution for The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali) 64 BIT:

sudo apt-get install build-essential cdbs fakeroot dh-make debhelper debconf libstdc++6 dkms libqtgui4 wget execstack libelfg0
sudo dpkg --get-selections | grep fglrx (If this gives any output then purge the package)

install the linux headers.. (I don't remember name..)

Then: goto:

cd /usr
sudo ln -svT lib /usr/lib64

Symlink the libraries as you will encounter an error after the install involving this..

Then download and INSTALL the BETA BETA BETA BETA BETA Driver for catalyst **NOT THE NORMAL ONE THE BETA ONE**. The install should go fine and then do the following command:

aticonfig --initial -f --adapters=all

now reboot.. then it should work.

Download the new version of hashcat and run it.
Did u manage to install it with success ? And then just it didn't recognize the driver ?
Yes, (On Ubuntu 13.10 with the BETA it installed perfectly after following these steps, and perfect speed for hashcat Tongue).

The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali) 64 should work as long as you update the kernel and insure you install the headers (make sure you use 64 bit and install the BETA).