Win7 32, Ati 5850, catalyst 14.9 but ERROR: clGetDeviceIDs() -1
I try to utilize oclHashcat, I prepare a new machine (clean machine) only with win7 SP1 32 pro (updated at today), an ATI 5850 and the version 14.9 of Catalyst.
When I run the program the error is:
clGetDeviceIDs() -1

I tried to reinstall the dirver: nothing.
I tried to install the latest Catalys: nothing.
Reverse to 14.9, nothing. installed SDK 2.7, 2.8, 2.9-1.599.381.... nothing

clinfo report the vga card correctly.
if I try with --force or with --gpu-devices=1 nothing change.

help me please.
Please follow this steps:
1. Uninstall the driver
2. Reboot
3. Remove all AMD SDKs (they are NOT needed, no, they may and do even conflict with the main driver)
4. Reboot
3. Use "Driver Fusion" program (the free version works perfectly) to remove the remaining graphic cards driver libs
4. Reboot
5. Download Catalyst 14.9 (exactly 14.9!)
6. Install Catalyst 14.9 driver
7. Reboot
8. Try again to run oclHashcat

If still not working after you have followed above steps, please pastebin the clinfo output.
I'm getting this with ALL my HD 5xxx series cards.

oclHashcat 1.31 works perfectly with cat 14.9

oclHashcat 1.32 has the below error with cat 14.9:

clGetDeviceIDs() -1



Been debugging with atom and setting the line below in your batch / cmd file will work around this for now:

oclHashcat.exe -m ... etc.
OK, after some debugging we found out the problem is related to GPU_NUM_COMPUTE_RINGS which we originally added to workaround some Catalyst 14.12 problems. Since we dropped support for catalyst 14.12 we can also safely remove this environment variable from the binary for oclHashcat v1.33.

To workaround the problem with oclHashcat v1.32, you need to set GPU_NUM_COMPUTE_RINGS to 0. This can be done either before you run oclHashcat from your cmdline or batch, or systemwide in windows settings.
with the variable:
all work perfectly, without changes.