the correct syntax to pipe maskprocessor | cudahashcat in linux?
tried almost everything.

cd /usr/share/maskprocessor && ./mp.bin -q 3 -r 4 ?d?d?d?d?d?d?d?d?d?d | cd /usr/share/cudahashcat/ && ./cudaHashcat64.bin -w 3 -t 10 -m 2500 /root/capture.hccap -a 3

while this is the correct path for both maskprocessor and cudahashcat, the whole syntax doesn't work. Any ideas what I'm doing wrong here? Really an example would have been really helpful.
why not just copy the mask processor to the cudahashcat dir?
Hi coolbry,

because that's the way it installed, but I might just do that.
:~# cd /usr/share/cudahashcat/ && ./mp64.bin -q 3 -r 4 ?d?d?d?d?d?d?d?d?d?d
./mp64.bin: /lib/x86_64-linux-gnu/ version `GLIBC_2.14' not found (required by ./mp64.bin)

what os do you have? sounds like you need to upgrade.
fresh/updated The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali) install.

How do you install maskprocessor? This is so weird.
try something like this. it should work

wget; 7za x cudaHashcat-1.33-nv-pdf-fix.7z; cd cudaHashcat-1.33; wget; 7za x maskprocessor-0.73.7z; ./mp64.bin -q 3 -r 4 ?d?d?d?d?d?d?d?d?d?d | ./cudaHashcat64.bin -w 3 -t 10 -m 2500 /root/capture.hccap -a 3

alright tried the commands myself didnt work. I did this without testing. Anyway the idea is to extract cudahashcat then put the extract maskprocessor then cp over maskprocessor to the cudahashcat dir.
./usr/share/maskprocessor/mp.bin -q 3 -r 4 ?d?d?d?d?d?d?d?d?d?d | /usr/share/cudahashcat/cudaHashcat64.bin -w 3 -t 10 -m 2500 /root/capture.hccap -a 3
your command does not do what you think it does. stdin mode implies wordlist attack. if you specify -a 3 it will ignore stdin, and you'll just be doing a mask attack with the default mask and threshold of 10.
Hi epixoip,

How can I limit the number of repetitions and frequency?

markov chains is very good, but still spews out things like "metassse" or "meta2777" So what I'm trying to do is eliminate 3 repetitions (555) and maximum of the same (5x5x5x5).

I'm trying to do that by piping maskprocessor in cudahashcat in a linux environment with the '-r' and '-q' arguments. I'm doing something wrong because it does not work.

atom referred me to PACK. That does not work for me.

@bsec, I will give that a go.