again : ERROR: clGetDeviceIDs() -1
Getting this same error, ERROR: clGetDeviceIDs() -1, but not really tracking what the recommended solution is.

Tried installing AMD-APP-SDK-v2.7-lnx32, but still getting the error.

Can someone provide a step-by-step on how to troubleshoot/fix?

AMD removed support for OpenCL for Win XP and hd4xxx. The hd2xxx and hd3xxx were never supported.
Is there anything in particular I can do to fix this error?
Somehow you forgot to post any details about your os, card model, so what help do you expect? Yes, it's sad to us all that *hashcat not work for you.
I'm running into this problem when trying to run oclHashcat-plus in a 32-bit BT5R3 VMWare VM on an iMac. The video card, a Radeon HD 4850, is supposedly supported.

I believe my problem is a faulty installation of OpenCL, which I'm working to fix. However, I'm wondering if the fact that I'm running in a VM will doom my efforts anyway. Is the error more likely the result of the VM or the problematic OpenCL install?

Thanks in advance.

AFAIK there is currently no way to get OpenCL for GPU working inside a VM.