hashcat-3.00
#1
hashcat-3.00-rc3 error immediately after launch:
Code:
hashcat (v3.00-beta-215-g1550b9d) starting...

=== Build failed, retry with optimization disabled ===
ERROR: clBuildProgram() : -11 : CL_BUILD_PROGRAM_FAILURE
=== Build Options : -I "D:\HASHCRACK\Hashcat\hashcat-3.00\OpenCL\" -D VENDOR_ID=1 -D CUDA_ARCH=0 -D VECT_SIZE=1 -D DEVICE_TYPE=4 -D
KERN_TYPE=2500 -D _unroll -cl-std=CL1.1 ===
=== Build Log (start) ===
"R:\TEMP\OCL1108T2.cl", line 10: catastrophic error: cannot open source file
          "inc_hash_constants.h"
  #include "inc_hash_constants.h"
                                 ^
1 catastrophic error detected in the compilation of "R:\TEMP\OCL1108T2.cl".
Compilation terminated.
Frontend phase failed compilation.
=== Build Log (end) ===
rc2, rc1 and beta-xx work fine

hashcat-3.00-rc2
and earlier versions strange fan operation:
Code:
hashcat (v3.00-beta-213-g268b1e3) starting...

HWMon.Dev.#1...: Temp: 42c Fan: 40% Util: 61% Core:1050Mhz Mem:1125Mhz Lanes:16
HWMon.Dev.#1...: Temp: 47c Fan: 40% Util: 97% Core:1050Mhz Mem:1125Mhz Lanes:16
HWMon.Dev.#1...: Temp: 57c Fan: 15% Util: 98% Core:1050Mhz Mem:1125Mhz Lanes:16
HWMon.Dev.#1...: Temp: 58c Fan: 15% Util: 98% Core:1050Mhz Mem:1125Mhz Lanes:16
HWMon.Dev.#1...: Temp: 59c Fan: 15% Util: 97% Core:1050Mhz Mem:1125Mhz Lanes:16
HWMon.Dev.#1...: Temp: 60c Fan: 15% Util: 75% Core:1050Mhz Mem:1125Mhz Lanes:16
HWMon.Dev.#1...: Temp: 63c Fan: 15% Util: 97% Core:1050Mhz Mem:1125Mhz Lanes:16
HWMon.Dev.#1...: Temp: 66c Fan: 15% Util: 87% Core:1050Mhz Mem:1125Mhz Lanes:16
HWMon.Dev.#1...: Temp: 67c Fan: 30% Util: 97% Core:1050Mhz Mem:1125Mhz Lanes:16
HWMon.Dev.#1...: Temp: 68c Fan: 45% Util: 97% Core:1050Mhz Mem:1125Mhz Lanes:16
HWMon.Dev.#1...: Temp: 69c Fan: 51% Util: 76% Core:1050Mhz Mem:1125Mhz Lanes:16
HWMon.Dev.#1...: Temp: 70c Fan: 88% Util: 98% Core:1050Mhz Mem:1125Mhz Lanes:16
HWMon.Dev.#1...: Temp: 70c Fan:100% Util: 98% Core:1050Mhz Mem:1125Mhz Lanes:16
===========
Windows 8.1 x64
GIGABYTE AMD Radeon HD7770 [GV-R777OC-1GD V2.0]
non-whql-64bit-radeon-software-crimson-16.6.1-win10-win8.1-win7-june2.exe
Reply
#2
There's rc4 now which should fix the path problematic on windows, the "catastrophic error".
The fanspeed changes is a new feature, you can turn it off by using --gpu-temp-retain 0.
Reply
#3
Fan speed control function is clearly useful. I'm just stating a fact that it works strange.
Temp: 42c - 47c | Fan: 40%
Temp: 57c - 66c | Fan: 15%
Temp: 67c - 70c | Fan: 100%

Thanks for your work
Reply
#4
Wow, actually this looks like a perfect temperature handling for me.

At the beginning for both safety reasons and maybe because your card was already a little bit warm/hot, the fan speed was set to a reasonable high value. After that it recognizes that the temperature is still a little bit below the --gpu-temp-retain value and acts accordingly.
Since the temperature raised again (now because of the cracking), fan speed was increases from 15 to 30, than 45, 51, 88 and finally 100% because the retain value was reached...
At some point in time the temperature will almost exactly hit the --gpu-temp-retain value and keep that value, while the fan speed might lower a little bit again (but in some cases - depending on GPU, cooling setup etc - it also could need to keep the fan at 100%.... in most cases, in my experience, it won't keep a constant 100% fan speed, at least for NVidia GPUs)
Reply
#5
If it helps, hashcat-3.00-rc5:
AfterBurner Screen | https://drive.google.com/open?id=0B_SHSv...0M0TVhPUk0
AfterBurner Log | https://drive.google.com/open?id=0B_SHSv...kEzOWppMXc
Reply
#6
Thanks for the screenshots. As philsmd already pointed out, that's the ideal handling.
Reply
#7
Fan control error in hashcat-3.00-rc19:
https://drive.google.com/open?id=0B_SHSv...jV1OFVCMms
Sorry, it's my fault. Accidentally turn the fan control in Afterburner to manual mode.


In hashcat-3.00 versions before rc16 (one of those that I have), default temperature retain trigger set to 65c, in later versions default temperature retain trigger set to 75c, so almost immediately activated temperature abort trigger, which is set by default on to 80c
Reply